diff mbox series

[meta-python,PATCHv2] python3-pyhamcrest: Upgrade 2.0.3 -> 2.0.4

Message ID 20220812132751.1589681-1-leon.anavi@konsulko.com
State Accepted, archived
Headers show
Series [meta-python,PATCHv2] python3-pyhamcrest: Upgrade 2.0.3 -> 2.0.4 | expand

Commit Message

Leon Anavi Aug. 12, 2022, 1:27 p.m. UTC
Upgrade to release 2.0.4:

- has_properties now returns Matcher[Any] type, which addresses
  type checking errors when nested as a matcher.
- Added Python 3.11 testing

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...yhamcrest_2.0.3.bb => python3-pyhamcrest_2.0.4.bb} | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-pyhamcrest_2.0.3.bb => python3-pyhamcrest_2.0.4.bb} (55%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.3.bb b/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.4.bb
similarity index 55%
rename from meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.3.bb
rename to meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.4.bb
index 5b06e52aa..888278af8 100644
--- a/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.4.bb
@@ -3,10 +3,13 @@  HOMEPAGE = "https://github.com/hamcrest/PyHamcrest"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=79391bf1501c898472d043f36e960612"
 
-PYPI_PACKAGE = "PyHamcrest"
-
-SRC_URI[sha256sum] = "dfb19cf6d71743e086fbb761ed7faea5aacbc8ec10c17a08b93ecde39192a3db"
+SRC_URI[sha256sum] = "b5d9ce6b977696286cf232ce2adf8969b4d0b045975b0936ac9005e84e67e9c1"
 
 inherit pypi python_setuptools_build_meta
 
-RDEPENDS:${PN} += "${PYTHON_PN}-six"
+DEPENDS += "${PYTHON_PN}-hatch-vcs-native"
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-six \
+    ${PYTHON_PN}-numbers \
+"