diff mbox series

[meta-python,4/4] python3-networkx: Upgrade 2.8.4 -> 2.8.5

Message ID 20220812132354.1588599-4-leon.anavi@konsulko.com
State Accepted, archived
Headers show
Series [meta-python,1/4] python3-nocasedict: Upgrade 1.0.3 -> 1.0.4 | expand

Commit Message

Leon Anavi Aug. 12, 2022, 1:23 p.m. UTC
Upgrade to release 2.8.5:

- Check that nodes have "pos" attribute in geometric_edges
- Correct louvain formula, solve infinite loops
- Add more comprehensive tests for pydot
- Move factory attributes to the class instead of instance
- make lazy_import private and remove its internal use

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-networkx_2.8.4.bb => python3-networkx_2.8.5.bb}  | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-networkx_2.8.4.bb => python3-networkx_2.8.5.bb} (78%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-networkx_2.8.4.bb b/meta-python/recipes-devtools/python/python3-networkx_2.8.5.bb
similarity index 78%
rename from meta-python/recipes-devtools/python/python3-networkx_2.8.4.bb
rename to meta-python/recipes-devtools/python/python3-networkx_2.8.5.bb
index 8181d90c0..8d0b8dbb3 100644
--- a/meta-python/recipes-devtools/python/python3-networkx_2.8.4.bb
+++ b/meta-python/recipes-devtools/python/python3-networkx_2.8.5.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "http://networkx.github.io/"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=44614b6df7cf3c19be69d0a945e29904"
 
-SRC_URI[sha256sum] = "5e53f027c0d567cf1f884dbb283224df525644e43afd1145d64c9d88a3584762"
+SRC_URI[sha256sum] = "15a7b81a360791c458c55a417418ea136c13378cfdc06a2dcdc12bd2f9cf09c1"
 
 inherit pypi setuptools3
 
@@ -16,4 +16,6 @@  RDEPENDS:${PN} += "\
                    ${PYTHON_PN}-html \
                    ${PYTHON_PN}-xml \
                    ${PYTHON_PN}-json \
+                   ${PYTHON_PN}-profile \
+                   ${PYTHON_PN}-threading \
                    "