python-numpy: move recipe to python directory

Message ID 20211113134505.353043-1-yi.zhao@windriver.com
State New
Headers show
Series python-numpy: move recipe to python directory | expand

Commit Message

Yi Zhao Nov. 13, 2021, 1:45 p.m. UTC
This recipe had been moved out from python directory since 2016[1] in
order to share patches between python2 and python3. But now there is no
reason to keep it in its own directory as we only keep python3-nump.
Move it back to python directory.

[1] https://git.openembedded.org/openembedded-core/commit/?id=9bffe2f9fb4ce6c0b265f27e5b484fbe076c6349

Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
---
 ...01-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch | 0
 .../python3-numpy}/0001-numpy-core-Define-RISCV-32-support.patch | 0
 .../{python-numpy/files => python/python3-numpy}/run-ptest       | 0
 .../{python-numpy => python}/python3-numpy_1.21.4.bb             | 1 +
 4 files changed, 1 insertion(+)
 rename meta/recipes-devtools/{python-numpy/files => python/python3-numpy}/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch (100%)
 rename meta/recipes-devtools/{python-numpy/files => python/python3-numpy}/0001-numpy-core-Define-RISCV-32-support.patch (100%)
 rename meta/recipes-devtools/{python-numpy/files => python/python3-numpy}/run-ptest (100%)
 rename meta/recipes-devtools/{python-numpy => python}/python3-numpy_1.21.4.bb (98%)

Comments

Richard Purdie Nov. 13, 2021, 4:27 p.m. UTC | #1
On Sat, 2021-11-13 at 21:45 +0800, Yi Zhao wrote:
> This recipe had been moved out from python directory since 2016[1] in
> order to share patches between python2 and python3. But now there is no
> reason to keep it in its own directory as we only keep python3-nump.
> Move it back to python directory.
> 
> [1] https://git.openembedded.org/openembedded-core/commit/?id=9bffe2f9fb4ce6c0b265f27e5b484fbe076c6349
> 
> Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
> ---
>  ...01-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch | 0
>  .../python3-numpy}/0001-numpy-core-Define-RISCV-32-support.patch | 0
>  .../{python-numpy/files => python/python3-numpy}/run-ptest       | 0
>  .../{python-numpy => python}/python3-numpy_1.21.4.bb             | 1 +
>  4 files changed, 1 insertion(+)
>  rename meta/recipes-devtools/{python-numpy/files => python/python3-numpy}/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch (100%)
>  rename meta/recipes-devtools/{python-numpy/files => python/python3-numpy}/0001-numpy-core-Define-RISCV-32-support.patch (100%)
>  rename meta/recipes-devtools/{python-numpy/files => python/python3-numpy}/run-ptest (100%)
>  rename meta/recipes-devtools/{python-numpy => python}/python3-numpy_1.21.4.bb (98%)
> 
> diff --git a/meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch b/meta/recipes-devtools/python/python3-numpy/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
> similarity index 100%
> rename from meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
> rename to meta/recipes-devtools/python/python3-numpy/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
> diff --git a/meta/recipes-devtools/python-numpy/files/0001-numpy-core-Define-RISCV-32-support.patch b/meta/recipes-devtools/python/python3-numpy/0001-numpy-core-Define-RISCV-32-support.patch
> similarity index 100%
> rename from meta/recipes-devtools/python-numpy/files/0001-numpy-core-Define-RISCV-32-support.patch
> rename to meta/recipes-devtools/python/python3-numpy/0001-numpy-core-Define-RISCV-32-support.patch
> diff --git a/meta/recipes-devtools/python-numpy/files/run-ptest b/meta/recipes-devtools/python/python3-numpy/run-ptest
> similarity index 100%
> rename from meta/recipes-devtools/python-numpy/files/run-ptest
> rename to meta/recipes-devtools/python/python3-numpy/run-ptest
> diff --git a/meta/recipes-devtools/python-numpy/python3-numpy_1.21.4.bb b/meta/recipes-devtools/python/python3-numpy_1.21.4.bb
> similarity index 98%
> rename from meta/recipes-devtools/python-numpy/python3-numpy_1.21.4.bb
> rename to meta/recipes-devtools/python/python3-numpy_1.21.4.bb
> index 8988a5bc39..a3ea4ab5aa 100644
> --- a/meta/recipes-devtools/python-numpy/python3-numpy_1.21.4.bb
> +++ b/meta/recipes-devtools/python/python3-numpy_1.21.4.bb
> @@ -47,6 +47,7 @@ RDEPENDS:${PN} = "${PYTHON_PN}-unittest \
>                    ${PYTHON_PN}-ctypes \
>                    ${PYTHON_PN}-threading \
>                    ${PYTHON_PN}-multiprocessing \
> +                  ${PYTHON_PN}-json \
>  "
>  RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest \
>                           ${PYTHON_PN}-hypothesis \

Looks like there is a dependency being changed too which isn't in the commit
message?

Cheers,

Richard
Yi Zhao Nov. 13, 2021, 4:49 p.m. UTC | #2
On 11/14/21 12:27 AM, Richard Purdie wrote:
> On Sat, 2021-11-13 at 21:45 +0800, Yi Zhao wrote:
>> This recipe had been moved out from python directory since 2016[1] in
>> order to share patches between python2 and python3. But now there is no
>> reason to keep it in its own directory as we only keep python3-nump.
>> Move it back to python directory.
>>
>> [1] https://git.openembedded.org/openembedded-core/commit/?id=9bffe2f9fb4ce6c0b265f27e5b484fbe076c6349
>>
>> Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
>> ---
>>   ...01-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch | 0
>>   .../python3-numpy}/0001-numpy-core-Define-RISCV-32-support.patch | 0
>>   .../{python-numpy/files => python/python3-numpy}/run-ptest       | 0
>>   .../{python-numpy => python}/python3-numpy_1.21.4.bb             | 1 +
>>   4 files changed, 1 insertion(+)
>>   rename meta/recipes-devtools/{python-numpy/files => python/python3-numpy}/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch (100%)
>>   rename meta/recipes-devtools/{python-numpy/files => python/python3-numpy}/0001-numpy-core-Define-RISCV-32-support.patch (100%)
>>   rename meta/recipes-devtools/{python-numpy/files => python/python3-numpy}/run-ptest (100%)
>>   rename meta/recipes-devtools/{python-numpy => python}/python3-numpy_1.21.4.bb (98%)
>>
>> diff --git a/meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch b/meta/recipes-devtools/python/python3-numpy/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
>> similarity index 100%
>> rename from meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
>> rename to meta/recipes-devtools/python/python3-numpy/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
>> diff --git a/meta/recipes-devtools/python-numpy/files/0001-numpy-core-Define-RISCV-32-support.patch b/meta/recipes-devtools/python/python3-numpy/0001-numpy-core-Define-RISCV-32-support.patch
>> similarity index 100%
>> rename from meta/recipes-devtools/python-numpy/files/0001-numpy-core-Define-RISCV-32-support.patch
>> rename to meta/recipes-devtools/python/python3-numpy/0001-numpy-core-Define-RISCV-32-support.patch
>> diff --git a/meta/recipes-devtools/python-numpy/files/run-ptest b/meta/recipes-devtools/python/python3-numpy/run-ptest
>> similarity index 100%
>> rename from meta/recipes-devtools/python-numpy/files/run-ptest
>> rename to meta/recipes-devtools/python/python3-numpy/run-ptest
>> diff --git a/meta/recipes-devtools/python-numpy/python3-numpy_1.21.4.bb b/meta/recipes-devtools/python/python3-numpy_1.21.4.bb
>> similarity index 98%
>> rename from meta/recipes-devtools/python-numpy/python3-numpy_1.21.4.bb
>> rename to meta/recipes-devtools/python/python3-numpy_1.21.4.bb
>> index 8988a5bc39..a3ea4ab5aa 100644
>> --- a/meta/recipes-devtools/python-numpy/python3-numpy_1.21.4.bb
>> +++ b/meta/recipes-devtools/python/python3-numpy_1.21.4.bb
>> @@ -47,6 +47,7 @@ RDEPENDS:${PN} = "${PYTHON_PN}-unittest \
>>                     ${PYTHON_PN}-ctypes \
>>                     ${PYTHON_PN}-threading \
>>                     ${PYTHON_PN}-multiprocessing \
>> +                  ${PYTHON_PN}-json \
>>   "
>>   RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest \
>>                            ${PYTHON_PN}-hypothesis \
> Looks like there is a dependency being changed too which isn't in the commit
> message?

Sorry that I forgot to mention it. I will send V2.


//Yi


>
> Cheers,
>
> Richard
>

Patch

diff --git a/meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch b/meta/recipes-devtools/python/python3-numpy/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
similarity index 100%
rename from meta/recipes-devtools/python-numpy/files/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
rename to meta/recipes-devtools/python/python3-numpy/0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch
diff --git a/meta/recipes-devtools/python-numpy/files/0001-numpy-core-Define-RISCV-32-support.patch b/meta/recipes-devtools/python/python3-numpy/0001-numpy-core-Define-RISCV-32-support.patch
similarity index 100%
rename from meta/recipes-devtools/python-numpy/files/0001-numpy-core-Define-RISCV-32-support.patch
rename to meta/recipes-devtools/python/python3-numpy/0001-numpy-core-Define-RISCV-32-support.patch
diff --git a/meta/recipes-devtools/python-numpy/files/run-ptest b/meta/recipes-devtools/python/python3-numpy/run-ptest
similarity index 100%
rename from meta/recipes-devtools/python-numpy/files/run-ptest
rename to meta/recipes-devtools/python/python3-numpy/run-ptest
diff --git a/meta/recipes-devtools/python-numpy/python3-numpy_1.21.4.bb b/meta/recipes-devtools/python/python3-numpy_1.21.4.bb
similarity index 98%
rename from meta/recipes-devtools/python-numpy/python3-numpy_1.21.4.bb
rename to meta/recipes-devtools/python/python3-numpy_1.21.4.bb
index 8988a5bc39..a3ea4ab5aa 100644
--- a/meta/recipes-devtools/python-numpy/python3-numpy_1.21.4.bb
+++ b/meta/recipes-devtools/python/python3-numpy_1.21.4.bb
@@ -47,6 +47,7 @@  RDEPENDS:${PN} = "${PYTHON_PN}-unittest \
                   ${PYTHON_PN}-ctypes \
                   ${PYTHON_PN}-threading \
                   ${PYTHON_PN}-multiprocessing \
+                  ${PYTHON_PN}-json \
 "
 RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest \
                          ${PYTHON_PN}-hypothesis \