[meta-java,13/15] openjdk-7: add depends on attr

Submitted by jackie huang on Dec. 25, 2015, 7:56 a.m. | Patch ID: 110857

Details

Message ID 617203e637ba0cca929a599b30e1cafdcadce639.1451029460.git.jackie.huang@windriver.com
State Accepted, archived
Delegated to: Otavio Salvador
Headers show

Commit Message

jackie huang Dec. 25, 2015, 7:56 a.m.
From: Amy Fong <amy.fong@windriver.com>

openjdk depends on attr, this can result in a configure
failure if the dependency is missing.

    checking for sys/epoll.h... (cached) yes
    checking attr/xattr.h usability... no
    checking attr/xattr.h presence... no
    checking for attr/xattr.h... no
    configure: error: Could not find required system headers;
      install the appropriate files from glibc-headers,
      libc6-dev and/or libattr-devel, libattr1-dev or use
      --disable-compile-against-syscalls if necessary.
    Configure failed. The contents of all config.log files follows to aid debugging

Signed-off-by: Amy Fong <amy.fong@windriver.com>
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
---
 recipes-core/openjdk/openjdk-7-common.inc | 1 +
 1 file changed, 1 insertion(+)

Patch hide | download patch | download mbox

diff --git a/recipes-core/openjdk/openjdk-7-common.inc b/recipes-core/openjdk/openjdk-7-common.inc
index 37f5911..a928103 100644
--- a/recipes-core/openjdk/openjdk-7-common.inc
+++ b/recipes-core/openjdk/openjdk-7-common.inc
@@ -32,6 +32,7 @@  DEPENDS = " \
     rhino krb5 \
     libxt libxinerama libxrender libxtst libxi \
     freetype alsa-lib libffi \
+    attr \
 "
 
 # No package should directly depend on this (it should require