diff mbox series

[meta-python] python3-pyflakes: upgrade 2.4.0 -> 2.5.0

Message ID 1659592133-4137-3-git-send-email-xuhuan.fnst@fujitsu.com
State New
Headers show
Series [meta-python] python3-pyflakes: upgrade 2.4.0 -> 2.5.0 | expand

Commit Message

XU Huan Aug. 4, 2022, 5:48 a.m. UTC
From: Xu Huan <xuhuan.fnst@fujitsu.com>

Changelog:
===========
    Drop support for EOL python 2.7 / 3.4 / 3.5
    Ignore __all__ when not directly assigned
    Handle TypeAlias annotations as aliases (PEP 613)
    Assignment expressions (:=) target outer scope in comprehensions
    Add support for new python 3.11 syntax
    Unify output so it is always filename:lineno:col: message
    Properly report SyntaxError from stdin in python < 3.9
    Fix offsets of "SyntaxError"s in pypy

Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com>
---
 .../{python3-pyflakes_2.4.0.bb => python3-pyflakes_2.5.0.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-pyflakes_2.4.0.bb => python3-pyflakes_2.5.0.bb} (73%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyflakes_2.4.0.bb b/meta-python/recipes-devtools/python/python3-pyflakes_2.5.0.bb
similarity index 73%
rename from meta-python/recipes-devtools/python/python3-pyflakes_2.4.0.bb
rename to meta-python/recipes-devtools/python/python3-pyflakes_2.5.0.bb
index 827ff0b292..5c75ea48aa 100644
--- a/meta-python/recipes-devtools/python/python3-pyflakes_2.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pyflakes_2.5.0.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://github.com/PyCQA/pyflakes"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=690c2d09203dc9e07c4083fc45ea981f"
 
-SRC_URI[sha256sum] = "05a85c2872edf37a4ed30b0cce2f6093e1d0581f8c19d7393122da7e25b2b24c"
+SRC_URI[sha256sum] = "491feb020dca48ccc562a8c0cbe8df07ee13078df59813b83959cbdada312ea3"
 
 inherit pypi setuptools3