diff mbox series

[meta-multimedia] vlc: add virtual/vlc alias

Message ID 20220730022855.50524-1-vince@underview.tech
State Under Review
Headers show
Series [meta-multimedia] vlc: add virtual/vlc alias | expand

Commit Message

Vincent Davis Jr July 30, 2022, 2:28 a.m. UTC
For layers that want to provide the ability to
select a version of VLC.

Signed-off-by: Vincent Davis Jr <vince@underview.tech>
---
 meta-multimedia/recipes-multimedia/vlc/vlc_3.0.17-1.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Ross Burton July 30, 2022, 7:32 p.m. UTC | #1
> On 30 Jul 2022, at 03:28, Vincent Davis Jr via lists.openembedded.org <vince=underview.tech@lists.openembedded.org> wrote:
> 
> For layers that want to provide the ability to
> select a version of VLC.

There’s no need for this.

If there’s just different versions, then have vlc_1.2.3.bb alongside vlc_1.0.0.bb and use PREFERRED_VERSION.

If you’ve got a fork, then just name it vlc-foo_1.2.3.bb and use PREFERRED_PROVIDER.

There’s no need to use virtual/ with PREFERRED_PROVIDER.  virtual/* should only be used when you want an abstract thing and there are many implementation, such as virtual/libc, which can be glibc, newlib, musl, etc.

Ross
Vincent Davis Jr July 30, 2022, 9:24 p.m. UTC | #2
Hey again Ross sorry I know I already sent this meant to hit reply all.

Meant to say for layers that contain recipes that clone different
implementations of VLC and want to allow the ability to select an
implementation. Would be nice to have PROVIDES = "virtual/vlc" here versus
multiple different layers providing bbappend files that add the PROVIDES
variable.

Working in PR were we want to allow either upstream implementation of VLC
or raspberry pi distro implementation.

https://github.com/agherzan/meta-raspberrypi/pull/985

On Sat, Jul 30, 2022, 14:32 Ross Burton <Ross.Burton@arm.com> wrote:

> > On 30 Jul 2022, at 03:28, Vincent Davis Jr via lists.openembedded.org
> <vince=underview.tech@lists.openembedded.org> wrote:
> >
> > For layers that want to provide the ability to
> > select a version of VLC.
>
> There’s no need for this.
>
> If there’s just different versions, then have vlc_1.2.3.bb alongside
> vlc_1.0.0.bb and use PREFERRED_VERSION.
>
> If you’ve got a fork, then just name it vlc-foo_1.2.3.bb and use
> PREFERRED_PROVIDER.
>
> There’s no need to use virtual/ with PREFERRED_PROVIDER.  virtual/* should
> only be used when you want an abstract thing and there are many
> implementation, such as virtual/libc, which can be glibc, newlib, musl, etc.
>
> Ross
Ross Burton July 31, 2022, 7:18 p.m. UTC | #3
> On 30 Jul 2022, at 22:24, Vincent Davis Jr via lists.openembedded.org <vince=underview.tech@lists.openembedded.org> wrote:
> 
> Hey again Ross sorry I know I already sent this meant to hit reply all.
> 
> Meant to say for layers that contain recipes that clone different implementations of VLC and want to allow the ability to select an implementation. Would be nice to have PROVIDES = "virtual/vlc" here versus multiple different layers providing bbappend files that add the PROVIDES variable.
> 
> Working in PR were we want to allow either upstream implementation of VLC or raspberry pi distro implementation.
> 
> https://github.com/agherzan/meta-raspberrypi/pull/985

I still don’t see the need: meta-raspberrypi’s vlc-rpi can PROVIDE vlc and set PREFERRED_PROVIDER.

Ross
Khem Raj July 31, 2022, 11:02 p.m. UTC | #4
On Sun, Jul 31, 2022 at 3:18 PM Ross Burton <ross.burton@arm.com> wrote:

>
> > On 30 Jul 2022, at 22:24, Vincent Davis Jr via lists.openembedded.org
> <vince=underview.tech@lists.openembedded.org> wrote:
> >
> > Hey again Ross sorry I know I already sent this meant to hit reply all.
> >
> > Meant to say for layers that contain recipes that clone different
> implementations of VLC and want to allow the ability to select an
> implementation. Would be nice to have PROVIDES = "virtual/vlc" here versus
> multiple different layers providing bbappend files that add the PROVIDES
> variable.
> >
> > Working in PR were we want to allow either upstream implementation of
> VLC or raspberry pi distro implementation.
> >
> > https://github.com/agherzan/meta-raspberrypi/pull/985
>
> I still don’t see the need: meta-raspberrypi’s vlc-rpi can PROVIDE vlc and
> set PREFERRED_PROVIDER.
>

Right I think calling recipe something like Vic-raspberrypi.bb and using
PREFERRED_PROVIDER is a good idea. This will let distros make the choice as
they see fit


> Ross
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#98067):
> https://lists.openembedded.org/g/openembedded-devel/message/98067
> Mute This Topic: https://lists.openembedded.org/mt/92704766/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc_3.0.17-1.bb b/meta-multimedia/recipes-multimedia/vlc/vlc_3.0.17-1.bb
index 9b85cb537..eff42496d 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc_3.0.17-1.bb
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc_3.0.17-1.bb
@@ -130,3 +130,5 @@  FILES:${PN}-staticdev += "\
 INSANE_SKIP:${PN} = "dev-so"
 
 EXCLUDE_FROM_WORLD = "${@bb.utils.contains("LICENSE_FLAGS_ACCEPTED", "commercial", "0", "1", d)}"
+
+PROVIDES = "virtual/vlc"