diff mbox series

[meta-python,1/2] Add python3-pycares 4.2.1

Message ID 20220726161032.1630170-1-brenda.streiff@ni.com
State New
Headers show
Series [meta-python,1/2] Add python3-pycares 4.2.1 | expand

Commit Message

Brenda Streiff July 26, 2022, 4:10 p.m. UTC
From: Sergey Kizunov <sergey.kizunov@ni.com>

pycares is an interface to the c-ares asynchronous DNS library.

Signed-off-by: Sergey Kizunov <sergey.kizunov@ni.com>

Updated and converted to new recipe syntax.

Signed-off-by: Brenda Streiff <brenda.streiff@ni.com>
---
 .../python/python3-pycares_4.2.1.bb           | 21 +++++++++++++++++++
 1 file changed, 21 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-pycares_4.2.1.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pycares_4.2.1.bb b/meta-python/recipes-devtools/python/python3-pycares_4.2.1.bb
new file mode 100644
index 000000000..dacaaa787
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pycares_4.2.1.bb
@@ -0,0 +1,21 @@ 
+SUMMARY = "Python interface for c-ares"
+DESCRIPTION = "\
+pycares is a Python module which provides an interface to c-ares. c-ares is \
+a C library that performs DNS requests and name resolutions asynchronously."
+HOMEPAGE = "https://github.com/saghul/pycares"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b1538fcaea82ebf2313ed648b96c69b1"
+
+SRC_URI[md5sum] = "92fa9622ba42cb895d598910722e80b5"
+SRC_URI[sha256sum] = "735b4f75fd0f595c4e9184da18cd87737f46bc81a64ea41f4edce2b6b68d46d2"
+
+PYPI_PACKAGE = "pycares"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-cffi-native"
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-cffi \
+    ${PYTHON_PN}-idna \
+"