diff mbox series

arm-bsp: add u-boot v2022.04 support

Message ID 20220722182216.3030-1-jon.mason@arm.com
State New
Headers show
Series arm-bsp: add u-boot v2022.04 support | expand

Commit Message

Jon Mason July 22, 2022, 6:22 p.m. UTC
Upstream has updated u-boot to v2022.07, but the update is causing
problems with some machines.  Temporarily add a v2022.04 recipe until
the issues can be resolved.

Signed-off-by: Jon Mason <jon.mason@arm.com>
---
 .../recipes-bsp/u-boot/u-boot_2022.04.bb      | 26 +++++++++++++++++++
 1 file changed, 26 insertions(+)
 create mode 100644 meta-arm-bsp/recipes-bsp/u-boot/u-boot_2022.04.bb

Comments

Jon Mason July 26, 2022, 8:48 p.m. UTC | #1
On Fri, 22 Jul 2022 14:22:16 -0400, Jon Mason wrote:
> Upstream has updated u-boot to v2022.07, but the update is causing
> problems with some machines.  Temporarily add a v2022.04 recipe until
> the issues can be resolved.

Applied, thanks!

[1/1] arm-bsp: add u-boot v2022.04 support
      commit: 64ddea94420fe8d1434ac1d4369b61646ddf0927

Best regards,
diff mbox series

Patch

diff --git a/meta-arm-bsp/recipes-bsp/u-boot/u-boot_2022.04.bb b/meta-arm-bsp/recipes-bsp/u-boot/u-boot_2022.04.bb
new file mode 100644
index 00000000..bc2d6d42
--- /dev/null
+++ b/meta-arm-bsp/recipes-bsp/u-boot/u-boot_2022.04.bb
@@ -0,0 +1,26 @@ 
+HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
+DESCRIPTION = "U-Boot, a boot loader for Embedded boards based on PowerPC, \
+ARM, MIPS and several other processors, which can be installed in a boot \
+ROM and used to initialize and test the hardware or to download and run \
+application code."
+SECTION = "bootloaders"
+DEPENDS += "flex-native bison-native"
+
+LICENSE = "GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=5a7450c57ffe5ae63fd732446b988025"
+PE = "1"
+
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "e4b6ebd3de982ae7185dbf689a030e73fd06e0d2"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master \
+          "
+
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+do_configure[cleandirs] = "${B}"
+
+require recipes-bsp/u-boot/u-boot.inc
+
+DEPENDS += "bc-native dtc-native"