[5/5] arm-bsp/trusted-firmware-a: move most BSPs to TF-A 2.6

Message ID 20211207181956.900131-5-ross.burton@arm.com
State New
Headers show
Series [1/5] trusted-firmware-a: don't use virtual/trusted-firmware-a | expand

Commit Message

Ross Burton Dec. 7, 2021, 6:19 p.m. UTC
Most BSPs don't need a specific release of TF-A, so add a bbappend for
TF-A 2.6 and remove the preferred version assignments.

Notable exceptions are TC0/TC1 and Corstone1000, which both are currently
using intermediate SHAs pre-2.6:

- TC0/TC1 fails to build with TF-A 2.6 as the binary doesn't fit in the
  specific space.

- Corstone1000 patches need to be rebased on top of 2.6

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta-arm-bsp/conf/machine/corstone500.conf         |  2 --
 meta-arm-bsp/conf/machine/fvp-common.inc           |  1 -
 meta-arm-bsp/conf/machine/include/corstone700.inc  |  2 --
 meta-arm-bsp/conf/machine/juno.conf                |  1 -
 meta-arm-bsp/conf/machine/n1sdp.conf               |  2 --
 meta-arm-bsp/conf/machine/sgi575.conf              |  2 --
 .../trusted-firmware-a_2.6.bbappend                | 14 ++++++++++++++
 7 files changed, 14 insertions(+), 10 deletions(-)
 create mode 100644 meta-arm-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_2.6.bbappend

Patch

diff --git a/meta-arm-bsp/conf/machine/corstone500.conf b/meta-arm-bsp/conf/machine/corstone500.conf
index c9ab4064..384a8dcf 100644
--- a/meta-arm-bsp/conf/machine/corstone500.conf
+++ b/meta-arm-bsp/conf/machine/corstone500.conf
@@ -14,8 +14,6 @@  require conf/machine/include/arm/armv7a/tune-cortexa5.inc
 PREFERRED_PROVIDER_virtual/kernel:forcevariable = "linux-yocto"
 PREFERRED_VERSION_linux-yocto ?= "5.3%"
 
-PREFERRED_VERSION_trusted-firmware-a ?= "2.5%"
-
 EXTRA_IMAGEDEPENDS += "trusted-firmware-a u-boot"
 
 SERIAL_CONSOLES = "115200;ttyAMA0"
diff --git a/meta-arm-bsp/conf/machine/fvp-common.inc b/meta-arm-bsp/conf/machine/fvp-common.inc
index 799260ec..a8fd60d9 100644
--- a/meta-arm-bsp/conf/machine/fvp-common.inc
+++ b/meta-arm-bsp/conf/machine/fvp-common.inc
@@ -15,7 +15,6 @@  SERIAL_CONSOLES = "115200;ttyAMA0"
 PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
 
 PREFERRED_VERSION_u-boot ?= "2021.10"
-PREFERRED_VERSION_trusted-firmware-a ?= "2.5%"
 
 EXTRA_IMAGEDEPENDS += "trusted-firmware-a u-boot"
 
diff --git a/meta-arm-bsp/conf/machine/include/corstone700.inc b/meta-arm-bsp/conf/machine/include/corstone700.inc
index 8a03c00d..fbb52776 100644
--- a/meta-arm-bsp/conf/machine/include/corstone700.inc
+++ b/meta-arm-bsp/conf/machine/include/corstone700.inc
@@ -11,8 +11,6 @@  SERIAL_CONSOLES ?= "115200;ttyAMA0"
 PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
 PREFERRED_VERSION_linux-yocto ?= "5.6%"
 
-PREFERRED_VERSION_trusted-firmware-a ?= "2.5%"
-
 PREFERRED_VERSION_gcc-arm-none-eabi-native ?= "9-2020-q2-update"
 
 PREFERRED_PROVIDER_virtual/control-processor-firmware ?= "boot-firmware"
diff --git a/meta-arm-bsp/conf/machine/juno.conf b/meta-arm-bsp/conf/machine/juno.conf
index 4a71d66d..86253adf 100644
--- a/meta-arm-bsp/conf/machine/juno.conf
+++ b/meta-arm-bsp/conf/machine/juno.conf
@@ -20,7 +20,6 @@  SERIAL_CONSOLES = "115200;ttyAMA0"
 # Use kernel provided by yocto
 PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
 PREFERRED_VERSION_linux-yocto ?= "5.4%"
-PREFERRED_VERSION_trusted-firmware-a ?= "2.5%"
 PREFERRED_VERSION_u-boot ?= "2020.07"
 
 EXTRA_IMAGEDEPENDS += "trusted-firmware-a u-boot firmware-image-juno"
diff --git a/meta-arm-bsp/conf/machine/n1sdp.conf b/meta-arm-bsp/conf/machine/n1sdp.conf
index 95a04c05..1fadbc10 100644
--- a/meta-arm-bsp/conf/machine/n1sdp.conf
+++ b/meta-arm-bsp/conf/machine/n1sdp.conf
@@ -25,8 +25,6 @@  PREFERRED_VERSION_linux-yocto-rt ?= "5.10%"
 # RTL8168E Gigabit Ethernet Controller is attached to the PCIe interface
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "linux-firmware-rtl8168"
 
-PREFERRED_VERSION_trusted-firmware-a ?= "2.5%"
-
 EXTRA_IMAGEDEPENDS += "trusted-firmware-a"
 EXTRA_IMAGEDEPENDS += "virtual/control-processor-firmware"
 
diff --git a/meta-arm-bsp/conf/machine/sgi575.conf b/meta-arm-bsp/conf/machine/sgi575.conf
index 7e1e6036..a384caa5 100644
--- a/meta-arm-bsp/conf/machine/sgi575.conf
+++ b/meta-arm-bsp/conf/machine/sgi575.conf
@@ -8,8 +8,6 @@  require conf/machine/include/arm/armv8-2a/tune-cortexa75.inc
 
 EXTRA_IMAGEDEPENDS += "virtual/control-processor-firmware"
 
-PREFERRED_VERSION_trusted-firmware-a ?= "2.5%"
-
 EXTRA_IMAGEDEPENDS += "trusted-firmware-a"
 
 KERNEL_IMAGETYPE ?= "Image"
diff --git a/meta-arm-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_2.6.bbappend b/meta-arm-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_2.6.bbappend
new file mode 100644
index 00000000..659ba352
--- /dev/null
+++ b/meta-arm-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_2.6.bbappend
@@ -0,0 +1,14 @@ 
+# Machine specific TFAs
+
+MACHINE_TFA_REQUIRE ?= ""
+MACHINE_TFA_REQUIRE:corstone500 = "trusted-firmware-a-corstone500.inc"
+MACHINE_TFA_REQUIRE:corstone700 = "trusted-firmware-a-corstone700.inc"
+MACHINE_TFA_REQUIRE:corstone1000 = "trusted-firmware-a-corstone1000.inc"
+MACHINE_TFA_REQUIRE:fvp-base = "trusted-firmware-a-fvp.inc"
+MACHINE_TFA_REQUIRE:fvp-base-arm32 = "trusted-firmware-a-fvp-arm32.inc"
+MACHINE_TFA_REQUIRE:juno = "trusted-firmware-a-juno.inc"
+MACHINE_TFA_REQUIRE:n1sdp = "trusted-firmware-a-n1sdp.inc"
+MACHINE_TFA_REQUIRE:sgi575 = "trusted-firmware-a-sgi575.inc"
+MACHINE_TFA_REQUIRE:tc = "trusted-firmware-a-tc.inc"
+
+require ${MACHINE_TFA_REQUIRE}