optee-ftpm: Limit to supported machines

Message ID 20211204012120.199942-1-raj.khem@gmail.com
State New
Headers show
Series optee-ftpm: Limit to supported machines | expand

Commit Message

Khem Raj Dec. 4, 2021, 1:21 a.m. UTC
If we build aarch64 based machines living outside meta-arm then these
recipes report as unsupported e.g.

ERROR: Nothing PROVIDES 'optee-os-tadevkit' (but /mnt/b/yoe/master/sources/meta-arm/meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb DEPENDS on or otherwise requires it)
optee-os-tadevkit was skipped: incompatible with machine rock-pi-4b (not in COMPATIBLE_MACHINE)
ERROR: Nothing RPROVIDES 'optee-ftpm' (but /mnt/b/yoe/master/sources/meta-arm/meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb RDEPENDS on or otherwise requires it)
No eligible RPROVIDERs exist for 'optee-ftpm'
NOTE: Runtime target 'optee-ftpm' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['optee-ftpm']
ERROR: Nothing RPROVIDES 'optee-ftpm-dev' (but /mnt/b/yoe/master/sources/meta-arm/meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb RDEPENDS on or otherwise requires it)
No eligible RPROVIDERs exist for 'optee-ftpm-dev'
NOTE: Runtime target 'optee-ftpm-dev' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['optee-ftpm-dev']

Therefore its better to limit this recipe to machines supporting
optee-os

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Jon Mason Dec. 6, 2021, 9:57 p.m. UTC | #1
On Fri, 3 Dec 2021 17:21:20 -0800, Khem Raj wrote:
> If we build aarch64 based machines living outside meta-arm then these
> recipes report as unsupported e.g.
> 
> ERROR: Nothing PROVIDES 'optee-os-tadevkit' (but /mnt/b/yoe/master/sources/meta-arm/meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb DEPENDS on or otherwise requires it)
> optee-os-tadevkit was skipped: incompatible with machine rock-pi-4b (not in COMPATIBLE_MACHINE)
> ERROR: Nothing RPROVIDES 'optee-ftpm' (but /mnt/b/yoe/master/sources/meta-arm/meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb RDEPENDS on or otherwise requires it)
> No eligible RPROVIDERs exist for 'optee-ftpm'
> NOTE: Runtime target 'optee-ftpm' is unbuildable, removing...
> Missing or unbuildable dependency chain was: ['optee-ftpm']
> ERROR: Nothing RPROVIDES 'optee-ftpm-dev' (but /mnt/b/yoe/master/sources/meta-arm/meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb RDEPENDS on or otherwise requires it)
> No eligible RPROVIDERs exist for 'optee-ftpm-dev'
> NOTE: Runtime target 'optee-ftpm-dev' is unbuildable, removing...
> Missing or unbuildable dependency chain was: ['optee-ftpm-dev']
> 
> [...]

Applied, thanks!

[1/1] optee-ftpm: Limit to supported machines
      commit: bf0b41be6a40f4fe9ddb2336d63c33d966d5287f

Best regards,

Patch

diff --git a/meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb b/meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb
index 22b51f4..e30e13a 100644
--- a/meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb
+++ b/meta-arm/recipes-security/optee-ftpm/optee-ftpm_git.bb
@@ -3,8 +3,9 @@  DESCRIPTION = "TCG reference implementation of the TPM 2.0 Specification."
 HOMEPAGE = "https://github.com/microsoft/ms-tpm-20-ref/"
 
 COMPATIBLE_MACHINE ?= "invalid"
-COMPATIBLE_MACHINE:aarch64 = "(.*)"
+COMPATIBLE_MACHINE:qemuarm64 = "qemuarm64"
 COMPATIBLE_MACHINE:qemuarm64-secureboot = "qemuarm64"
+COMPATIBLE_MACHINE:qemu-generic-arm64 = "qemu-generic-arm64"
 
 #FIXME - doesn't currently work with clang
 TOOLCHAIN = "gcc"