diff mbox series

[meta-python,2/3] python3-email-validator: Upgrade 1.1.3 -> 1.2.1

Message ID 20220708131949.48129-2-leon.anavi@konsulko.com
State New
Headers show
Series [meta-python,1/3] python3-tornado: Upgrade 6.1 -> 6.2 | expand

Commit Message

Leon Anavi July 8, 2022, 1:19 p.m. UTC
Upgrade to release 1.2.1:

- Rejecting domains with NULL MX records (when deliverability
  checks are turned on).
- Rejecting unsafe unicode characters. (Some of these checks you
  should be doing on all of your user inputs already!)
- Rejecting most special-use reserved domain names. A new
  test_environment option is added for using @*.test domains.
- Some fixes in the tests.
- example and example.com/net/org are removed from the special-use
  domains list.
- SPECIAL_USE_DOMAIN_NAMES is now a documented part of the API
  (and it is a list instead of a tuple)
- New module-level attributes ALLOW_SMTPUTF8, CHECK_DELIVERABILITY,
  TEST_ENVIRONMENT, and DEFAULT_TIMEOUT can be used to change the
  default values of the keyword arguments.
- Travis CI is updated to test from Python 3.6 forward,
  dropping 3.5.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...ail-validator_1.1.3.bb => python3-email-validator_1.2.1.bb} | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-email-validator_1.1.3.bb => python3-email-validator_1.2.1.bb} (68%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-email-validator_1.1.3.bb b/meta-python/recipes-devtools/python/python3-email-validator_1.2.1.bb
similarity index 68%
rename from meta-python/recipes-devtools/python/python3-email-validator_1.1.3.bb
rename to meta-python/recipes-devtools/python/python3-email-validator_1.2.1.bb
index b81e39a15..a5cb09fd9 100644
--- a/meta-python/recipes-devtools/python/python3-email-validator_1.1.3.bb
+++ b/meta-python/recipes-devtools/python/python3-email-validator_1.2.1.bb
@@ -3,8 +3,7 @@  SECTION = "devel/python"
 LICENSE = "CC0-1.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=65d3616852dbf7b1a6d4b53b00626032"
 
-SRC_URI[md5sum] = "25582cf3d415c7fdd44b980a095e0d53"
-SRC_URI[sha256sum] = "aa237a65f6f4da067119b7df3f13e89c25c051327b2b5b66dc075f33d62480d7"
+SRC_URI[sha256sum] = "6757aea012d40516357c0ac2b1a4c31219ab2f899d26831334c5d069e8b6c3d8"
 
 PYPI_PACKAGE = "email_validator"