diff mbox series

[master/kirkstone,22/50] optee-os: Lower log level for AM62x

Message ID 20221104224653.1223044-23-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series 2022.10 sync up with Dunfell | expand

Commit Message

Denys Dmytriyenko Nov. 4, 2022, 10:46 p.m. UTC
From: Andrew Davis <afd@ti.com>

During resume from low power mode suspend OP-TEE prints some messages
on the UART. It seems this UART is not powered at this point in the
sequence breaking suspend/resume. We should track down the exact
prints and quiet them. Until we get that fix upstream, lets lower
the log level for this platform to unblock the LPM work.

Signed-off-by: Andrew Davis <afd@ti.com>
Acked-by: Anand Gadiyar <gadiyar@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend
index 76f55257..3c4383ba 100644
--- a/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend
+++ b/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend
@@ -3,7 +3,7 @@  SRCREV:ti-soc = "8e155bae3a5eb9d1a3ed9260bd7281a7a35f5086"
 
 EXTRA_OEMAKE:append:k3 = "${@ ' CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}"
 
-EXTRA_OEMAKE:append:am62xx = " CFG_WITH_SOFTWARE_PRNG=y"
+EXTRA_OEMAKE:append:am62xx = " CFG_WITH_SOFTWARE_PRNG=y CFG_TEE_CORE_LOG_LEVEL=1"
 EXTRA_OEMAKE:append:j721s2 = " CFG_WITH_SOFTWARE_PRNG=y"
 
 do_compile:prepend:ti-soc() {