[meta-ti,dunfell,v2,4/5] ti-graphics: Add j721s2-hs-evm as a compatible machine

Message ID 20220607103529.13068-5-j-choudhary@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series Add J721S2 HS platform support | expand

Commit Message

Jayesh Choudhary June 7, 2022, 10:35 a.m. UTC
Add HS platform to the list of compatible machines.

Signed-off-by: Jayesh Choudhary <j-choudhary@ti.com>
---
 .../powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb       | 4 +++-
 recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb  | 3 ++-
 2 files changed, 5 insertions(+), 2 deletions(-)

Comments

Nishanth Menon June 8, 2022, 6:09 p.m. UTC | #1
On 16:05-20220607, Jayesh Choudhary via lists.yoctoproject.org wrote:
> Add HS platform to the list of compatible machines.
> 
> Signed-off-by: Jayesh Choudhary <j-choudhary@ti.com>
> ---
>  .../powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb       | 4 +++-
>  recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb  | 3 ++-
>  2 files changed, 5 insertions(+), 2 deletions(-)
> 
> diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
> index 718c7845..3a20d809 100644
> --- a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
> +++ b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
> @@ -11,7 +11,7 @@ MACHINE_KERNEL_PR_append = "b"
>  PR = "${MACHINE_KERNEL_PR}"
>  
>  PACKAGE_ARCH = "${MACHINE_ARCH}"
> -COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|am62xx"
> +COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|j721s2-hs-evm|am62xx"
>  
>  DEPENDS = "virtual/kernel"
>  
> @@ -31,10 +31,12 @@ SRCREV = "6d3d62a15ceb85b719c35f34c6c9e35f556b406b"
>  TARGET_PRODUCT_j7-evm = "j721e_linux"
>  TARGET_PRODUCT_j7-hs-evm = "j721e_linux"
>  TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
> +TARGET_PRODUCT_j721s2-hs-evm = "j721s2_linux"

^^ DDK km build does'nt again change based on board.. so why are we
doint this based on board?

>  TARGET_PRODUCT_am62xx = "am62_linux"
>  TARGET_BVNC_j7-evm = "22.104.208.318"
>  TARGET_BVNC_j7-hs-evm = "22.104.208.318"
>  TARGET_BVNC_j721s2-evm = "36.53.104.796"
> +TARGET_BVNC_j721s2-hs-evm = "36.53.104.796"

BVNC does'nt change based on evm - so why are we do it based on board?

>  TARGET_BVNC_am62xx = "33.15.11.3"
>  PVR_BUILD = "release"
>  PVR_WS = "wayland"
> diff --git a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
> index 1bfb2b93..7921d17b 100644
> --- a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
> +++ b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
> @@ -8,7 +8,7 @@ inherit features_check
>  REQUIRED_MACHINE_FEATURES = "gpu"
>  
>  PACKAGE_ARCH = "${MACHINE_ARCH}"
> -COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|am62xx"
> +COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|j721s2-hs-evm|am62xx"
>  
>  PR = "r2"
>  
> @@ -20,6 +20,7 @@ SRCREV = "fba0c770b712640ab3761dbe8369d43f89f616ed"
>  TARGET_PRODUCT_j7-evm = "j721e_linux"
>  TARGET_PRODUCT_j7-hs-evm = "j721e_linux"
>  TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
> +TARGET_PRODUCT_j721s2-hs-evm = "j721s2_linux"

^^ Same question here as well.. am62xx seems to have done it right.

>  TARGET_PRODUCT_am62xx = "am62_linux"
>  PVR_BUILD ?= "release"
>  PVR_WS = "wayland"
> -- 
> 2.17.1
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#14790): https://lists.yoctoproject.org/g/meta-ti/message/14790
> Mute This Topic: https://lists.yoctoproject.org/mt/91597544/5513541
> Group Owner: meta-ti+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/meta-ti/unsub [nm@ti.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Denys Dmytriyenko June 8, 2022, 7:23 p.m. UTC | #2
On Wed, Jun 08, 2022 at 01:09:21PM -0500, Nishanth Menon via lists.yoctoproject.org wrote:
> On 16:05-20220607, Jayesh Choudhary via lists.yoctoproject.org wrote:
> > Add HS platform to the list of compatible machines.
> > 
> > Signed-off-by: Jayesh Choudhary <j-choudhary@ti.com>
> > ---
> >  .../powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb       | 4 +++-
> >  recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb  | 3 ++-
> >  2 files changed, 5 insertions(+), 2 deletions(-)
> > 
> > diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
> > index 718c7845..3a20d809 100644
> > --- a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
> > +++ b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
> > @@ -11,7 +11,7 @@ MACHINE_KERNEL_PR_append = "b"
> >  PR = "${MACHINE_KERNEL_PR}"
> >  
> >  PACKAGE_ARCH = "${MACHINE_ARCH}"
> > -COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|am62xx"
> > +COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|j721s2-hs-evm|am62xx"
> >  
> >  DEPENDS = "virtual/kernel"
> >  
> > @@ -31,10 +31,12 @@ SRCREV = "6d3d62a15ceb85b719c35f34c6c9e35f556b406b"
> >  TARGET_PRODUCT_j7-evm = "j721e_linux"
> >  TARGET_PRODUCT_j7-hs-evm = "j721e_linux"
> >  TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
> > +TARGET_PRODUCT_j721s2-hs-evm = "j721s2_linux"
> 
> ^^ DDK km build does'nt again change based on board.. so why are we
> doint this based on board?

Platform and DDK cleanup went into kirkstone/master, but not dunfell.


> >  TARGET_PRODUCT_am62xx = "am62_linux"
> >  TARGET_BVNC_j7-evm = "22.104.208.318"
> >  TARGET_BVNC_j7-hs-evm = "22.104.208.318"
> >  TARGET_BVNC_j721s2-evm = "36.53.104.796"
> > +TARGET_BVNC_j721s2-hs-evm = "36.53.104.796"
> 
> BVNC does'nt change based on evm - so why are we do it based on board?
> 
> >  TARGET_BVNC_am62xx = "33.15.11.3"
> >  PVR_BUILD = "release"
> >  PVR_WS = "wayland"
> > diff --git a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
> > index 1bfb2b93..7921d17b 100644
> > --- a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
> > +++ b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
> > @@ -8,7 +8,7 @@ inherit features_check
> >  REQUIRED_MACHINE_FEATURES = "gpu"
> >  
> >  PACKAGE_ARCH = "${MACHINE_ARCH}"
> > -COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|am62xx"
> > +COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|j721s2-hs-evm|am62xx"
> >  
> >  PR = "r2"
> >  
> > @@ -20,6 +20,7 @@ SRCREV = "fba0c770b712640ab3761dbe8369d43f89f616ed"
> >  TARGET_PRODUCT_j7-evm = "j721e_linux"
> >  TARGET_PRODUCT_j7-hs-evm = "j721e_linux"
> >  TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
> > +TARGET_PRODUCT_j721s2-hs-evm = "j721s2_linux"
> 
> ^^ Same question here as well.. am62xx seems to have done it right.
> 
> >  TARGET_PRODUCT_am62xx = "am62_linux"
> >  PVR_BUILD ?= "release"
> >  PVR_WS = "wayland"
> > -- 
> > 2.17.1

Patch

diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
index 718c7845..3a20d809 100644
--- a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
+++ b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb
@@ -11,7 +11,7 @@  MACHINE_KERNEL_PR_append = "b"
 PR = "${MACHINE_KERNEL_PR}"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|am62xx"
+COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|j721s2-hs-evm|am62xx"
 
 DEPENDS = "virtual/kernel"
 
@@ -31,10 +31,12 @@  SRCREV = "6d3d62a15ceb85b719c35f34c6c9e35f556b406b"
 TARGET_PRODUCT_j7-evm = "j721e_linux"
 TARGET_PRODUCT_j7-hs-evm = "j721e_linux"
 TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
+TARGET_PRODUCT_j721s2-hs-evm = "j721s2_linux"
 TARGET_PRODUCT_am62xx = "am62_linux"
 TARGET_BVNC_j7-evm = "22.104.208.318"
 TARGET_BVNC_j7-hs-evm = "22.104.208.318"
 TARGET_BVNC_j721s2-evm = "36.53.104.796"
+TARGET_BVNC_j721s2-hs-evm = "36.53.104.796"
 TARGET_BVNC_am62xx = "33.15.11.3"
 PVR_BUILD = "release"
 PVR_WS = "wayland"
diff --git a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
index 1bfb2b93..7921d17b 100644
--- a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
+++ b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.15.6133109.bb
@@ -8,7 +8,7 @@  inherit features_check
 REQUIRED_MACHINE_FEATURES = "gpu"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|am62xx"
+COMPATIBLE_MACHINE = "j7-evm|j7-hs-evm|j721s2-evm|j721s2-hs-evm|am62xx"
 
 PR = "r2"
 
@@ -20,6 +20,7 @@  SRCREV = "fba0c770b712640ab3761dbe8369d43f89f616ed"
 TARGET_PRODUCT_j7-evm = "j721e_linux"
 TARGET_PRODUCT_j7-hs-evm = "j721e_linux"
 TARGET_PRODUCT_j721s2-evm = "j721s2_linux"
+TARGET_PRODUCT_j721s2-hs-evm = "j721s2_linux"
 TARGET_PRODUCT_am62xx = "am62_linux"
 PVR_BUILD ?= "release"
 PVR_WS = "wayland"