[master,10/10] dsptop: fix host contamination warning

Message ID 20220509175947.1994132-11-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series sync up with Dunfell 08.03.00.003 | expand

Commit Message

Denys Dmytriyenko May 9, 2022, 5:59 p.m. UTC
From: Denys Dmytriyenko <denys@konsulko.com>

Fixes this warning:

| WARNING: dsptop-1.4.0-r2.2 do_package_qa: QA Issue: dsptop: /usr/bin/dsptop is owned by uid 1000,
| which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated]

Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 meta-ti-extras/recipes-bsp/dsptop/dsptop_git.bb | 1 +
 1 file changed, 1 insertion(+)

Patch

diff --git a/meta-ti-extras/recipes-bsp/dsptop/dsptop_git.bb b/meta-ti-extras/recipes-bsp/dsptop/dsptop_git.bb
index e8853ff8..90ce8943 100644
--- a/meta-ti-extras/recipes-bsp/dsptop/dsptop_git.bb
+++ b/meta-ti-extras/recipes-bsp/dsptop/dsptop_git.bb
@@ -15,6 +15,7 @@  EXTRA_OEMAKE = "release DEVICE=${DEVICE} CROSS_COMPILE=${TARGET_PREFIX} CC="${CC
 
 do_install() {
     oe_runmake install DESTDIR=${D}
+    chown -R root:root ${D}
 }
 
 COMPATIBLE_MACHINE = "dra7xx"