diff mbox series

[meta-python] recipes-devtools/python3-gspread: interface for google spreadsheet

Message ID bfcfacfd-2484-55db-2c33-2c2e5fbd9b1e@3mdeb.com
State New
Headers show
Series [meta-python] recipes-devtools/python3-gspread: interface for google spreadsheet | expand

Commit Message

Daniil Klimuk Aug. 16, 2023, 8:43 a.m. UTC
Author: Daniil Klimuk <daniil.klimuk@3mdeb.com>
Date:   Mon Aug 14 15:46:40 2023 +0200

     recipes-devtools/python3-gspread: interface for google spreadsheet

     Simple interface for working with Google Sheets.

     Signed-off-by: Daniil Klimuk <daniil.klimuk@3mdeb.com>

+RDEPENDS:${PN} = "python3-requests"
+
+inherit python_poetry_core

Comments

Khem Raj Aug. 16, 2023, 2:29 p.m. UTC | #1
On Wed, Aug 16, 2023 at 1:43 AM Danik <daniil.klimuk@3mdeb.com> wrote:

> Author: Daniil Klimuk <daniil.klimuk@3mdeb.com>
> Date:   Mon Aug 14 15:46:40 2023 +0200
>
>      recipes-devtools/python3-gspread: interface for google spreadsheet
>
>      Simple interface for working with Google Sheets.
>
>      Signed-off-by: Daniil Klimuk <daniil.klimuk@3mdeb.com>
>
> diff --git
> a/meta-python/recipes-devtools/python3-gspread/python3-gspread_5.10.0.bb
> b/meta-python/recipes-devtools/python3-gspread/python3-gspread_5.10.0.bb
> new file mode 100644
> index 000000000000..e13e452353cd
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python3-gspread/
> python3-gspread_5.10.0.bb
> @@ -0,0 +1,15 @@
> +SUMMARY = "Google Spreadsheets Python API"
> +HOMEPAGE = "https://github.com/burnash/gspread"
> +AUTHOR = "Anton Burnashev <fuss.here@gmail.com>"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM =
> "file://LICENSE.txt;md5=9488e21983675fa56dc05af558b83e2f"
> +
> +SRC_URI =
> "
> https://files.pythonhosted.org/packages/b4/4f/033ebf34778745061b67b104ef212ed5b05fa65a530f345f88c4355fdcc3/gspread-5.10.0.tar.gz
> "
> +SRC_URI[md5sum] = "f21198e80a50d0e6d557d9fea6a79e8e"
> +SRC_URI[sha256sum] =
> "2b6bba6dc111580170346a9bcd1893e0e8c52f67a9e537caec7b7a1e27c14435"
> +
> +S = "${WORKDIR}/gspread-5.10.0"


Use PV instead of hardcoding 5.10.0 here


> +
> +RDEPENDS:${PN} = "python3-requests"
> +
> +inherit python_poetry_core
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104419):
> https://lists.openembedded.org/g/openembedded-devel/message/104419
> Mute This Topic: https://lists.openembedded.org/mt/100775688/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Khem Raj Aug. 16, 2023, 4:39 p.m. UTC | #2
On 8/16/23 1:43 AM, Danik wrote:
> Author: Daniil Klimuk <daniil.klimuk@3mdeb.com>
> Date:   Mon Aug 14 15:46:40 2023 +0200
> 
>      recipes-devtools/python3-gspread: interface for google spreadsheet

Subject should be

recipe: Short summary

Description of patch

Signed-off-by:


This link here [1] is handy to learn about submitting patches to OE

> 
>      Simple interface for working with Google Sheets.
> 
>      Signed-off-by: Daniil Klimuk <daniil.klimuk@3mdeb.com>
> 
> diff --git 
> a/meta-python/recipes-devtools/python3-gspread/python3-gspread_5.10.0.bb 
> b/meta-python/recipes-devtools/python3-gspread/python3-gspread_5.10.0.bb
> new file mode 100644
> index 000000000000..e13e452353cd
> --- /dev/null
> +++ 
> b/meta-python/recipes-devtools/python3-gspread/python3-gspread_5.10.0.bb
> @@ -0,0 +1,15 @@
> +SUMMARY = "Google Spreadsheets Python API"
> +HOMEPAGE = "https://github.com/burnash/gspread"
> +AUTHOR = "Anton Burnashev <fuss.here@gmail.com>"

Drop AUTHOR field, we do not use it anymore

> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = 
> "file://LICENSE.txt;md5=9488e21983675fa56dc05af558b83e2f"
> +
> +SRC_URI = 
> "https://files.pythonhosted.org/packages/b4/4f/033ebf34778745061b67b104ef212ed5b05fa65a530f345f88c4355fdcc3/gspread-5.10.0.tar.gz"
> +SRC_URI[md5sum] = "f21198e80a50d0e6d557d9fea6a79e8e"

drop dm5sum, its deprecated.

> +SRC_URI[sha256sum] = 
> "2b6bba6dc111580170346a9bcd1893e0e8c52f67a9e537caec7b7a1e27c14435"
> +
> +S = "${WORKDIR}/gspread-5.10.0"

use PV instead of 5.10.0 here

> +

[1] https://www.openembedded.org/wiki/How_to_submit_a_patch_to_OpenEmbedded
diff mbox series

Patch

diff --git 
a/meta-python/recipes-devtools/python3-gspread/python3-gspread_5.10.0.bb 
b/meta-python/recipes-devtools/python3-gspread/python3-gspread_5.10.0.bb
new file mode 100644
index 000000000000..e13e452353cd
--- /dev/null
+++ b/meta-python/recipes-devtools/python3-gspread/python3-gspread_5.10.0.bb
@@ -0,0 +1,15 @@ 
+SUMMARY = "Google Spreadsheets Python API"
+HOMEPAGE = "https://github.com/burnash/gspread"
+AUTHOR = "Anton Burnashev <fuss.here@gmail.com>"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = 
"file://LICENSE.txt;md5=9488e21983675fa56dc05af558b83e2f"
+
+SRC_URI = 
"https://files.pythonhosted.org/packages/b4/4f/033ebf34778745061b67b104ef212ed5b05fa65a530f345f88c4355fdcc3/gspread-5.10.0.tar.gz"
+SRC_URI[md5sum] = "f21198e80a50d0e6d557d9fea6a79e8e"
+SRC_URI[sha256sum] = 
"2b6bba6dc111580170346a9bcd1893e0e8c52f67a9e537caec7b7a1e27c14435"
+
+S = "${WORKDIR}/gspread-5.10.0"
+