diff mbox series

[meta-oe,v3] jwt-cpp: add recipe

Message ID CAD6RADDDwCV8mnAzL68r2X28yJHXnk-Rcxh9MzqCZVXg6GOrFQ@mail.gmail.com
State New
Headers show
Series [meta-oe,v3] jwt-cpp: add recipe | expand

Commit Message

Boas Meier Oct. 26, 2022, 6:26 a.m. UTC
From 02b6a81c2a98bcc0a643f20d1e96d14b4269db30 Mon Sep 17 00:00:00 2001
From: Boas Meier <boas.meier@siemens.com>
Date: Tue, 25 Oct 2022 11:28:40 +0200
Subject: [PATCH 1/1] jwt-cpp: add v0.6.0

Signed-off-by: Boas Meier <boas.meier@siemens.com>
---
 .../recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb  | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
 create mode 100644 meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb

+
+EXTRA_OECMAKE += "-DJWT_BUILD_EXAMPLES=OFF
-DJWT_CMAKE_FILES_INSTALL_DIR=${libdir}/cmake"

Comments

Khem Raj Oct. 26, 2022, 2:03 p.m. UTC | #1
the patch seems to not apply perhaps due to malformed characters in
it. Can you check and see if your mailer is ok

On Tue, Oct 25, 2022 at 11:27 PM Meier Boas <boas.meier@gmail.com> wrote:
>
> From 02b6a81c2a98bcc0a643f20d1e96d14b4269db30 Mon Sep 17 00:00:00 2001
> From: Boas Meier <boas.meier@siemens.com>
> Date: Tue, 25 Oct 2022 11:28:40 +0200
> Subject: [PATCH 1/1] jwt-cpp: add v0.6.0
>
> Signed-off-by: Boas Meier <boas.meier@siemens.com>
> ---
>  .../recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb  | 18 ++++++++++++++++++
>  1 file changed, 18 insertions(+)
>  create mode 100644 meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb
>
> diff --git a/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb b/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb
> new file mode 100644
> index 000000000..8929115fd
> --- /dev/null
> +++ b/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb
> @@ -0,0 +1,18 @@
> +SUMMARY = "A header only library for creating and validating json web tokens in c++"
> +HOMEPAGE = "https://thalhammer.github.io/jwt-cpp/"
> +SECTION = "libs"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=8325a5ce4414c65ffdda392e0d96a9ff"
> +
> +SRC_URI = "git://github.com/Thalhammer/jwt-cpp.git;branch=master;protocol=https \
> +            "
> +
> +SRCREV = "4a537e969891dde542ad8b1a4a214955a83be29f"
> +
> +S = "${WORKDIR}/git"
> +
> +DEPENDS = "openssl"
> +
> +inherit cmake
> +
> +EXTRA_OECMAKE += "-DJWT_BUILD_EXAMPLES=OFF -DJWT_CMAKE_FILES_INSTALL_DIR=${libdir}/cmake"
> --
> 2.30.2
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#99310): https://lists.openembedded.org/g/openembedded-devel/message/99310
> Mute This Topic: https://lists.openembedded.org/mt/94576306/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb
b/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb
new file mode 100644
index 000000000..8929115fd
--- /dev/null
+++ b/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb
@@ -0,0 +1,18 @@ 
+SUMMARY = "A header only library for creating and validating json web
tokens in c++"
+HOMEPAGE = "https://thalhammer.github.io/jwt-cpp/"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8325a5ce4414c65ffdda392e0d96a9ff"
+
+SRC_URI = "git://
github.com/Thalhammer/jwt-cpp.git;branch=master;protocol=https \
+            "
+
+SRCREV = "4a537e969891dde542ad8b1a4a214955a83be29f"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "openssl"
+
+inherit cmake