diff mbox series

[meta-oe,v2] jwt-cpp: add recipe

Message ID CAD6RADBEPh-m7N4Xmf_GuLP+Q+zm1FMUBoQF1Wsr+UBsUkrF-w@mail.gmail.com
State New
Headers show
Series [meta-oe,v2] jwt-cpp: add recipe | expand

Commit Message

Boas Meier Oct. 25, 2022, 12:11 p.m. UTC
From d3daf755814f0cff7e57bb521520fe6a52685050 Mon Sep 17 00:00:00 2001
From: Boas Meier <boas.meier@siemens.com>
Date: Tue, 25 Oct 2022 11:28:40 +0200
Subject: [PATCH 1/1] jwt-cpp: add v0.6.0

Signed-off-by: Boas Meier <boas.meier@siemens.com>
---
 .../recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb | 20 +++++++++++++++++++
 1 file changed, 20 insertions(+)
 create mode 100644 meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb

+
+FILES:${PN} = "/usr/cmake"

Comments

Khem Raj Oct. 25, 2022, 3:12 p.m. UTC | #1
On Tue, Oct 25, 2022 at 5:12 AM Meier Boas <boas.meier@gmail.com> wrote:
>
> From d3daf755814f0cff7e57bb521520fe6a52685050 Mon Sep 17 00:00:00 2001
> From: Boas Meier <boas.meier@siemens.com>
> Date: Tue, 25 Oct 2022 11:28:40 +0200
> Subject: [PATCH 1/1] jwt-cpp: add v0.6.0
>
> Signed-off-by: Boas Meier <boas.meier@siemens.com>
> ---
>  .../recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb | 20 +++++++++++++++++++
>  1 file changed, 20 insertions(+)
>  create mode 100644 meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb
>
> diff --git a/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb b/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb
> new file mode 100644
> index 000000000..bd3baa863
> --- /dev/null
> +++ b/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb
> @@ -0,0 +1,20 @@
> +SUMMARY = "A header only library for creating and validating json web tokens in c++"
> +HOMEPAGE = "https://thalhammer.github.io/jwt-cpp/"
> +SECTION = "libs"
> +LICENSE = "MIT"
> +LIC_FILES_CHECKSUM = "file://LICENSE;md5=8325a5ce4414c65ffdda392e0d96a9ff"
> +
> +SRC_URI = "git://github.com/Thalhammer/jwt-cpp.git;branch=master;protocol=https \
> +            "
> +
> +SRCREV = "4a537e969891dde542ad8b1a4a214955a83be29f"
> +
> +S = "${WORKDIR}/git"
> +
> +DEPENDS = "openssl"
> +
> +inherit cmake
> +
> +EXTRA_OECMAKE += "-DJWT_BUILD_EXAMPLES=OFF"
> +
> +FILES:${PN} = "/usr/cmake"

/usr/cmake is a rather unusual location. Can you investigate it a bit
more and figure out if we can have its content packaged under
${datadir}/cmake or ${libdir}/cmake depending upon what it contains.

> --
> 2.30.2
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#99306): https://lists.openembedded.org/g/openembedded-devel/message/99306
> Mute This Topic: https://lists.openembedded.org/mt/94556657/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb
b/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb
new file mode 100644
index 000000000..bd3baa863
--- /dev/null
+++ b/meta-oe/recipes-devtools/jwt-cpp/jwt-cpp_0.6.0.bb
@@ -0,0 +1,20 @@ 
+SUMMARY = "A header only library for creating and validating json web
tokens in c++"
+HOMEPAGE = "https://thalhammer.github.io/jwt-cpp/"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHECKSUM = "file://LICENSE;md5=8325a5ce4414c65ffdda392e0d96a9ff"
+
+SRC_URI = "git://
github.com/Thalhammer/jwt-cpp.git;branch=master;protocol=https \
+            "
+
+SRCREV = "4a537e969891dde542ad8b1a4a214955a83be29f"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "openssl"
+
+inherit cmake
+
+EXTRA_OECMAKE += "-DJWT_BUILD_EXAMPLES=OFF"