diff mbox series

[meta-python,31/60] python3-multidict: switch to pytest --automake

Message ID 58092086ab5b86a1c5c110acd0874900c23627fd.1708127759.git.tim.orling@konsulko.com
State Accepted
Headers show
Series [meta-python,01/60] python3-uritemplate: switch to pytest --automake | expand

Commit Message

Tim Orling Feb. 17, 2024, 12:15 a.m. UTC
* Also replace ${PYTHON_PN} with python3

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 .../recipes-devtools/python/python3-multidict/run-ptest      | 2 +-
 .../recipes-devtools/python/python3-multidict_6.0.4.bb       | 5 +++--
 2 files changed, 4 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-multidict/run-ptest b/meta-python/recipes-devtools/python/python3-multidict/run-ptest
index e4f3b623ab..d74acaf564 100644
--- a/meta-python/recipes-devtools/python/python3-multidict/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-multidict/run-ptest
@@ -1,2 +1,2 @@ 
 #!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-multidict_6.0.4.bb b/meta-python/recipes-devtools/python/python3-multidict_6.0.4.bb
index b057e05f65..19b94dee02 100644
--- a/meta-python/recipes-devtools/python/python3-multidict_6.0.4.bb
+++ b/meta-python/recipes-devtools/python/python3-multidict_6.0.4.bb
@@ -18,8 +18,9 @@  SRC_URI += " \
 "
 
 RDEPENDS:${PN}-ptest += " \
-	${PYTHON_PN}-pytest \
-	${PYTHON_PN}-pytest-cov \
+    python3-pytest \
+    python3-pytest-cov \
+    python3-unittest-automake-output \
 "
 
 do_install_ptest() {