diff mbox series

[meta-python,2/4] python3-wxgtk4: Fix build with gcc-14

Message ID 20240510005731.2074507-2-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,1/4] fvwm: Fix build with gcc-14 | expand

Commit Message

Khem Raj May 10, 2024, 12:57 a.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../0001-sip-Fix-build-with-gcc-14.patch      | 31 +++++++++++++++++++
 .../python3-wxgtk4/python3-wxgtk4_4.2.1.bb    |  1 +
 2 files changed, 32 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4/0001-sip-Fix-build-with-gcc-14.patch
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4/0001-sip-Fix-build-with-gcc-14.patch b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4/0001-sip-Fix-build-with-gcc-14.patch
new file mode 100644
index 0000000000..4782e74ef3
--- /dev/null
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4/0001-sip-Fix-build-with-gcc-14.patch
@@ -0,0 +1,31 @@ 
+From 5234a454a1b9f11f83e59909fb2972176497e02c Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 9 May 2024 17:35:11 -0700
+Subject: [PATCH] sip: Fix build with gcc-14
+
+Fixes -Wincompatible-pointer-types
+sip/siplib/siplib.c:3900:20: error: assignment to 'sipSimpleWrapper *' {aka 'struct _sipSimpleWrapper *'} from incompatible pointer type 'PyObject *' {aka 'struct _object *'} [-Wincompatible-pointer-types]
+|  3900 |             *selfp = va_arg(va, PyObject *);
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ sip/siplib/siplib.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/sip/siplib/siplib.c b/sip/siplib/siplib.c
+index 95563e5c..ae3fac60 100644
+--- a/sip/siplib/siplib.c
++++ b/sip/siplib/siplib.c
+@@ -3897,7 +3897,7 @@ static int parsePass1(PyObject **parseErrp, sipSimpleWrapper **selfp,
+     {
+     case '#':
+             /* A ctor has an argument with the /Transfer/ annotation. */
+-            *selfp = va_arg(va, PyObject *);
++            *selfp = (sipSimpleWrapper *)va_arg(va, PyObject *);
+             break;
+ 
+     case 'B':
+-- 
+2.45.0
+
diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.2.1.bb b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.2.1.bb
index fb011cb71b..cc6b6cef67 100644
--- a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.2.1.bb
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.2.1.bb
@@ -14,6 +14,7 @@  SRC_URI += "file://add-back-option-build-base.patch \
            file://wxgtk-fixup-build-scripts.patch \
            file://not-overwrite-cflags-cxxflags.patch \
            file://0001-sip-Conditionally-use-GetAssertStackTrace-under-USE_.patch \
+           file://0001-sip-Fix-build-with-gcc-14.patch \
            "
 SRC_URI[sha256sum] = "e48de211a6606bf072ec3fa778771d6b746c00b7f4b970eb58728ddf56d13d5c"