diff mbox series

[meta-python,kirkstone] python3-pyyaml-include: Drop pytest --automake

Message ID 20240430085308.1401971-1-mingli.yu@windriver.com
State New
Headers show
Series [meta-python,kirkstone] python3-pyyaml-include: Drop pytest --automake | expand

Commit Message

Yu, Mingli April 30, 2024, 8:53 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

The python3-unittest-automake-output is not supported [1], so drop
"pytest --automake".

[1] https://lore.kernel.org/all/20240327072236.2221619-1-mingli.yu@windriver.com/T/#mda91919809cf156aba24f099bef65142067cd318

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 .../recipes-devtools/python/python3-pyyaml-include/run-ptest    | 2 +-
 .../recipes-devtools/python/python3-pyyaml-include_1.4.1.bb     | 1 -
 2 files changed, 1 insertion(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest b/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest
index 8d2017d39..3385d6893 100755
--- a/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-pyyaml-include/run-ptest
@@ -1,3 +1,3 @@ 
 #!/bin/sh
 
-pytest --automake
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-pyyaml-include_1.4.1.bb b/meta-python/recipes-devtools/python/python3-pyyaml-include_1.4.1.bb
index 6768e959f..b60a0f9c8 100644
--- a/meta-python/recipes-devtools/python/python3-pyyaml-include_1.4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyyaml-include_1.4.1.bb
@@ -24,6 +24,5 @@  RDEPENDS:${PN} += " \
 "
 RDEPENDS:${PN}-ptest += " \
     python3-pytest \
-    python3-unittest-automake-output \
 "