diff mbox series

[meta-python,kirkstone,2/2] python3-twisted: Add python3-asyncio to RDEPENDS

Message ID 20240404224522.4303-2-gudnimar@noxmedical.com
State New
Headers show
Series [meta-python,kirkstone,1/2] python3-twisted: Add python3-typing-extensions to RDEPENDS | expand

Commit Message

Guðni Már Gilbert April 4, 2024, 10:45 p.m. UTC
From: Hains van den Bosch <hainsvdbosch@ziggo.nl>

To fix crash due to missing module:

from twisted.internet import defer
File "/usr/lib/python3.11/site-packages/twisted/internet/defer.py", line 14, in <module>
from asyncio import AbstractEventLoop, Future, iscoroutine
ModuleNotFoundError: No module named 'asyncio'

Signed-off-by: Hains van den Bosch <hainsvdbosch@ziggo.nl>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Guðni Már Gilbert <gudnimar@noxmedical.com>
---
 meta-python/recipes-devtools/python/python3-twisted_22.2.0.bb | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-twisted_22.2.0.bb b/meta-python/recipes-devtools/python/python3-twisted_22.2.0.bb
index 3225b6c98..c55c86ea5 100644
--- a/meta-python/recipes-devtools/python/python3-twisted_22.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twisted_22.2.0.bb
@@ -57,6 +57,7 @@  RDEPENDS:${PN} = "\
 "
 
 RDEPENDS:${PN}-core = "${PYTHON_PN}-appdirs \
+                       ${PYTHON_PN}-asyncio \
                        ${PYTHON_PN}-automat \
                        ${PYTHON_PN}-constantly \
                        ${PYTHON_PN}-core \