diff mbox series

[meta-python,kirkstone,3/3] python3-pyyaml-include: Upgrade 1.3.2 -> 1.4.1

Message ID 20240327071636.2207445-3-mingli.yu@windriver.com
State New
Headers show
Series [meta-python,kirkstone,1/3] python3-pyyaml-include: add initial recipe for version 1.3.2 | expand

Commit Message

Yu, Mingli March 27, 2024, 7:16 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

* Upgrade to 1.4.1 to make it work with setuptools 59.x as it doesn't
support pep 621 [1], so remove pyproject.toml and add setup.cfg back [2].

* Add python3-toml to RDEPENDS to fix below error:
 self = <yamlinclude.readers.TomlReader object at 0x7faceccdbd30>

     def __call__(self):
         if sys.version_info >= (3, 11):
             with open(self._path, "rb") as fp:
                 return tomllib.load(fp)
         else:
             try:
                 import toml
             except ImportError as err:  # pragma: no cover
 >               raise ImportError(f'Un-supported file "{self._path}".\n`pip install toml` should solve the problem.\n\n{err}')
 E               ImportError: Un-supported file "tests/data/include.d/1.toml".
 E               `pip install toml` should solve the problem.
 E
 E               No module named 'toml'

 ../../python3.10/site-packages/yamlinclude/readers.py:69: ImportError

[1] https://setuptools.pypa.io/en/latest/userguide/pyproject_config.html
[2] https://github.com/tanbro/pyyaml-include/issues/43

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 ...aml-include_1.3.2.bb => python3-pyyaml-include_1.4.1.bb} | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-pyyaml-include_1.3.2.bb => python3-pyyaml-include_1.4.1.bb} (86%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyyaml-include_1.3.2.bb b/meta-python/recipes-devtools/python/python3-pyyaml-include_1.4.1.bb
similarity index 86%
rename from meta-python/recipes-devtools/python/python3-pyyaml-include_1.3.2.bb
rename to meta-python/recipes-devtools/python/python3-pyyaml-include_1.4.1.bb
index 3a5bd99a7..6768e959f 100644
--- a/meta-python/recipes-devtools/python/python3-pyyaml-include_1.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pyyaml-include_1.4.1.bb
@@ -2,11 +2,10 @@  SUMMARY = "Extending PyYAML with a custom constructor for including YAML files w
 HOMEPAGE = "https://github.com/tanbro/pyyaml-include"
 LICENSE = "GPL-3.0-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
-DEPENDS += "python3-setuptools-scm-native"
-SRCREV = "36b6975aa8fc7a6cbf37de40aa2ed6d996b2f7be"
+SRCREV = "0f86bf16343d2ad52b53b793e0b35bb7ed7cd85b"
 
 SRC_URI = " \
-            git://github.com/tanbro/pyyaml-include;protocol=https;branch=main \
+            git://github.com/tanbro/pyyaml-include;protocol=https;branch=1.x \
             file://run-ptest \
           "
 
@@ -21,6 +20,7 @@  do_install_ptest() {
 
 RDEPENDS:${PN} += " \
     python3-pyyaml \
+    python3-toml \
 "
 RDEPENDS:${PN}-ptest += " \
     python3-pytest \