diff mbox series

[meta-oe,v4,2/7] lvgl: install lv_conf.h

Message ID 20240316100056.409758-2-chris.chapuis@gmail.com
State New
Headers show
Series [meta-oe,v4,1/7] lvgl: fix typo in lv-conf.inc | expand

Commit Message

Christophe Chapuis March 16, 2024, 10 a.m. UTC
Add an install append to copy the generated lv_conf.h as part of the
lvgl package, so that it will be found and used by the recipes that
want to use lvgl.

Signed-off-by: Christophe Chapuis <chris.chapuis@gmail.com>
---
 meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Marek Vasut March 16, 2024, 8:41 p.m. UTC | #1
On 3/16/24 11:00 AM, Christophe Chapuis wrote:
> Add an install append to copy the generated lv_conf.h as part of the
> lvgl package, so that it will be found and used by the recipes that
> want to use lvgl.
> 
> Signed-off-by: Christophe Chapuis <chris.chapuis@gmail.com>
> ---
>   meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb | 5 +++++
>   1 file changed, 5 insertions(+)
> 
> diff --git a/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb b/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb
> index b84fc5a3d..58053d830 100644
> --- a/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb
> +++ b/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb
> @@ -26,6 +26,11 @@ ALLOW_EMPTY:${PN} = "1"
>   PACKAGECONFIG ??= "drm"
>   require lv-conf.inc
>   
> +do_install:append() {
> +    install -d "${D}${includedir}/${PN}"
> +    install -m 0644 "${S}/lv_conf.h" "${D}${includedir}/${PN}/lv_conf.h"
> +}

Reviewed-by: Marek Vasut <marex@denx.de>
diff mbox series

Patch

diff --git a/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb b/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb
index b84fc5a3d..58053d830 100644
--- a/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb
+++ b/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb
@@ -26,6 +26,11 @@  ALLOW_EMPTY:${PN} = "1"
 PACKAGECONFIG ??= "drm"
 require lv-conf.inc
 
+do_install:append() {
+    install -d "${D}${includedir}/${PN}"
+    install -m 0644 "${S}/lv_conf.h" "${D}${includedir}/${PN}/lv_conf.h"
+}
+
 FILES:${PN}-dev += "\
     ${includedir}/${PN}/ \
     ${includedir}/${PN}/lvgl/ \