diff mbox series

[meta-oe,1/2] abseil-cpp: A little clean-up

Message ID 20240311130322.1867704-1-pkj@axis.com
State Accepted
Headers show
Series [meta-oe,1/2] abseil-cpp: A little clean-up | expand

Commit Message

Peter Kjellerstedt March 11, 2024, 1:03 p.m. UTC
* Remove ASNEEDED:class-native and ASNEEDED:class-nativesdk as they make
  no difference since ${ASNEEDED} is only added to TARGET_LDFLAGS.
* Remove additions to FILES:${PN}-dev since the added paths are already
  added by default.

Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
---

This restores the two commits that were (presumably) acidentally
reverted in commit 903c8e58ed2240f7214261c9005a38f15d782c29.

 .../recipes-devtools/abseil-cpp/abseil-cpp_20240116.1.bb | 9 ++-------
 1 file changed, 2 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240116.1.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240116.1.bb
index 82b2d20e0..9cb325870 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240116.1.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240116.1.bb
@@ -1,7 +1,7 @@ 
 SUMMARY = "Abseil is a cpp library like STL"
 DESCRIPTION = "Abseil provides pieces missing from the C++ standard. Contains \
 additional useful libraries like algorithm, container, debugging, hash, memory, \
-meta, numeric, strings, synchronization, time, types and utility"
+meta, numeric, strings, synchronization, time, types and utility."
 HOMEPAGE = "https://abseil.io/"
 SECTION = "libs"
 LICENSE = "Apache-2.0"
@@ -18,9 +18,6 @@  SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \
 
 S = "${WORKDIR}/git"
 
-ASNEEDED:class-native = ""
-ASNEEDED:class-nativesdk = ""
-
 inherit cmake
 
 EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
@@ -28,8 +25,6 @@  EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
                  -DABSL_ENABLE_INSTALL=ON \
                 "
 
-BBCLASSEXTEND = "native nativesdk"
-
 SYSROOT_DIRS:append:class-nativesdk:mingw32 = " ${bindir}"
 
-FILES:${PN}-dev += "${includedir} ${libdir}/cmake ${libdir}/pkgconfig"
+BBCLASSEXTEND = "native nativesdk"