diff mbox series

[meta-python,2/3] python3-responses: add recipe

Message ID 20240308055136.81476-2-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python,1/3] python3-pytest-localserver: added recipe which is also include ptest | expand

Commit Message

Alper Ak March 8, 2024, 5:51 a.m. UTC
A utility library for mocking out the requests Python library.

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 Couldn't add ptest because throwing ERROR: Exited from signal Killed (9) after 300 sec. 
 When I tried with tox after cloning the upstream in docker, there was no problem. Somehow this error is encountered in QEMU. 
 This could happen for a variety of reasons, such as running out of memory, being killed by the system due to resource constraints, or potentially due to a bug in the code.

 .../python/python3-responses_0.25.0.bb            | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-responses_0.25.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-responses_0.25.0.bb b/meta-python/recipes-devtools/python/python3-responses_0.25.0.bb
new file mode 100644
index 000000000..f4b59c750
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-responses_0.25.0.bb
@@ -0,0 +1,15 @@ 
+DESCRIPTION = "A utility library for mocking out the requests Python library."
+HOMEPAGE = "https://github.com/getsentry/responses"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0e601511a8517f4daf688a8eb95be7a2"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "01ae6a02b4f34e39bffceb0fc6786b67a25eae919c6368d05eabc8d9576c2a66"
+
+RDEPENDS:${PN} += " \
+	python3-mock \
+	python3-pyyaml \
+	python3-requests \
+	python3-urllib3 \
+"