diff mbox series

python3-ordered-set: Use automake formatter for ptest output

Message ID 20240222190658.2483441-1-raj.khem@gmail.com
State Accepted, archived
Headers show
Series python3-ordered-set: Use automake formatter for ptest output | expand

Commit Message

Khem Raj Feb. 22, 2024, 7:06 p.m. UTC
Move the test to PTESTS_FAST_META_PYTHON

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-python/conf/include/ptest-packagelists-meta-python.inc     | 2 +-
 .../recipes-devtools/python/python3-ordered-set/run-ptest       | 2 +-
 .../recipes-devtools/python/python3-ordered-set_4.1.0.bb        | 1 +
 3 files changed, 3 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 790d5b019d..6903157cec 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -29,6 +29,7 @@  PTESTS_FAST_META_PYTHON = "\
     python3-jsmin \
     python3-msgpack \
     python3-multidict \
+    python3-ordered-set \
     python3-parse \
     python3-parse-type \
     python3-platformdirs \
@@ -76,7 +77,6 @@  PTESTS_PROBLEMS_META_PYTHON ="\
     python3-dnspython \
     python3-fastjsonschema \
     python3-gpiod \
-    python3-ordered-set \
     python3-pillow \
     python3-pint \
     python3-pyzmq \
diff --git a/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest b/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest
index c27a6c3c57..64799ba008 100644
--- a/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-ordered-set/run-ptest
@@ -1,3 +1,3 @@ 
 #!/bin/sh
 
-pytest test_ordered_set.py
+pytest --automake test_ordered_set.py
diff --git a/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb b/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb
index a391036a73..64637b858d 100644
--- a/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb
@@ -15,6 +15,7 @@  SRC_URI += " \
 
 RDEPENDS:${PN}-ptest += " \
 	python3-pytest \
+	python3-unittest-automake-output \
 "
 
 do_install_ptest() {