diff mbox series

[meta-gnome,PATCHv2] gedit: update 46.1 -> 46.2

Message ID 20240220071934.10184-1-f_l_k@t-online.de
State Accepted
Headers show
Series [meta-gnome,PATCHv2] gedit: update 46.1 -> 46.2 | expand

Commit Message

Markus Volk Feb. 20, 2024, 7:19 a.m. UTC
Signed-off-by: Markus Volk <f_l_k@t-online.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../gedit/gedit/0001-fix-for-clang-18.patch   | 32 +++++++++++++++++++
 .../gedit/{gedit_46.1.bb => gedit_46.2.bb}    |  3 +-
 2 files changed, 34 insertions(+), 1 deletion(-)
 create mode 100644 meta-gnome/recipes-gnome/gedit/gedit/0001-fix-for-clang-18.patch
 rename meta-gnome/recipes-gnome/gedit/{gedit_46.1.bb => gedit_46.2.bb} (89%)
diff mbox series

Patch

diff --git a/meta-gnome/recipes-gnome/gedit/gedit/0001-fix-for-clang-18.patch b/meta-gnome/recipes-gnome/gedit/gedit/0001-fix-for-clang-18.patch
new file mode 100644
index 000000000..40fd93b98
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gedit/gedit/0001-fix-for-clang-18.patch
@@ -0,0 +1,32 @@ 
+Signed-off-by: Markus Volk <f_l_k@t-online.de>
+Upstream-Status: Inappropriate [https://gitlab.gnome.org/GNOME/gedit/-/issues/588]
+
+Temporary workaround to fix build:
+../plugins/quickhighlight/gedit-quick-highlight-plugin.c: In function ‘gedit_quick_highlight_plugin_load_style’:
+../plugins/quickhighlight/gedit-quick-highlight-plugin.c:96:47: error: implicit declaration of function ‘gtk_source_style_copy’; did you mean ‘gtk_source_style_apply’? [-Wimplicit-function-declaration]
+
+   96 |                         plugin->priv->style = gtk_source_style_copy (style);
+      |                                               ^~~~~~~~~~~~~~~~~~~~~
+      |                                               gtk_source_style_apply
+../plugins/quickhighlight/gedit-quick-highlight-plugin.c:96:47: warning: nested extern declaration of ‘gtk_source_style_copy’ [-Wnested-externs]
+../plugins/quickhighlight/gedit-quick-highlight-plugin.c:96:45: error: assignment to ‘GtkSourceStyle *’ {aka ‘struct _GtkSourceStyle *’} from ‘int’ makes pointer from integer without a cast [-Wint-conversion]
+   96 |                         plugin->priv->style = gtk_source_style_copy (style);
+      |                                             ^
+
+--- a/plugins/quickhighlight/gedit-quick-highlight-plugin.c	2024-02-20 08:11:47.925749255 +0100
++++ b/plugins/quickhighlight/gedit-quick-highlight-plugin.c	2024-02-20 08:12:16.218594067 +0100
+@@ -90,11 +90,12 @@
+ 	if (style_scheme != NULL)
+ 	{
+ 		style = gtk_source_style_scheme_get_style (style_scheme, "quick-highlight-match");
+-
++#if 0
+ 		if (style != NULL)
+ 		{
+ 			plugin->priv->style = gtk_source_style_copy (style);
+ 		}
++#endif
+ 	}
+ }
+ 
+
diff --git a/meta-gnome/recipes-gnome/gedit/gedit_46.1.bb b/meta-gnome/recipes-gnome/gedit/gedit_46.2.bb
similarity index 89%
rename from meta-gnome/recipes-gnome/gedit/gedit_46.1.bb
rename to meta-gnome/recipes-gnome/gedit/gedit_46.2.bb
index c0221b9a7..6cdc33c1c 100644
--- a/meta-gnome/recipes-gnome/gedit/gedit_46.1.bb
+++ b/meta-gnome/recipes-gnome/gedit/gedit_46.2.bb
@@ -23,7 +23,8 @@  inherit gnomebase gsettings itstool gnome-help gobject-introspection gtk-doc get
 def gnome_verdir(v):
     return oe.utils.trim_version(v, 1)
 
-SRC_URI[archive.sha256sum] = "a1a6e37f041765dff7227a1f5578b6f49faaf016b1e17e869caf5bfb94c6aa4e"
+SRC_URI += "file://0001-fix-for-clang-18.patch"
+SRC_URI[archive.sha256sum] = "c0866412bad147ebace2d282ffcbb5a0e9a304b20fd55640bee21c81e6d501ef"
 
 # gobject-introspection is mandatory and cannot be configured
 REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"