diff mbox series

[meta-python,v2] whitenoise: add a new recipe

Message ID 20240212161821.776532-1-fathi.boudra@linaro.org
State Accepted
Headers show
Series [meta-python,v2] whitenoise: add a new recipe | expand

Commit Message

Fathi Boudra Feb. 12, 2024, 4:18 p.m. UTC
Radically simplified static file serving for Python web apps

With a couple of lines of config WhiteNoise allows your web app
to serve its own static files, making it a self-contained unit
that can be deployed anywhere without relying on nginx, Amazon S3
or any other external service.

https://whitenoise.readthedocs.io/en/latest/

Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
---

Changes since v1:
 * get rid of the patch and inherit from python_setuptools_build_meta

 .../python/python3-whitenoise_6.6.0.bb        | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-whitenoise_6.6.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-whitenoise_6.6.0.bb b/meta-python/recipes-devtools/python/python3-whitenoise_6.6.0.bb
new file mode 100644
index 0000000000..352a53769a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-whitenoise_6.6.0.bb
@@ -0,0 +1,19 @@ 
+SUMMARY = "Radically simplified static file serving for WSGI applications"
+AUTHOR = "David Evans <d@evans.io>"
+HOMEPAGE = "https://whitenoise.evans.io"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=aba4901cc64e401cea5a267eac2a2e1e"
+
+PYPI_PACKAGE = "whitenoise"
+
+SRC_URI[sha256sum] = "8998f7370973447fac1e8ef6e8ded2c5209a7b1f67c1012866dbcd09681c3251"
+
+inherit pypi python_setuptools_build_meta
+
+RDEPENDS:${PN}:append = " \
+    python3-brotli \
+    python3-coverage \
+    python3-django \
+    python3-pytest \
+    python3-requests \
+"