diff mbox series

[meta-python] python3-eth-account: upgrade 0.10.0 -> 0.11.0

Message ID 20240206055519.22317-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python] python3-eth-account: upgrade 0.10.0 -> 0.11.0 | expand

Commit Message

Alper Ak Feb. 6, 2024, 5:55 a.m. UTC
Changelog:

Breaking Changes

    Drop support for python 3.7

Internal Changes - for eth-account Contributors

    Change older % and .format strings to use f-strings
    Merge template updates, notably use pre-commit for linting and change the name of the master branch to main

Removals

    Remove deprecated signTransaction, it has been replaced by sign_transaction

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../python/python3-eth-account_0.10.0.bb      | 18 -----------------
 .../python/python3-eth-account_0.11.0.bb      | 20 +++++++++++++++++++
 2 files changed, 20 insertions(+), 18 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-eth-account_0.10.0.bb
 create mode 100644 meta-python/recipes-devtools/python/python3-eth-account_0.11.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-eth-account_0.10.0.bb b/meta-python/recipes-devtools/python/python3-eth-account_0.10.0.bb
deleted file mode 100644
index 1854e3bca..000000000
--- a/meta-python/recipes-devtools/python/python3-eth-account_0.10.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@ 
-SUMMARY = "Assign Ethereum transactions and messages with local private keys."
-HOMEPAGE = "https://github.com/ethereum/eth-account"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=16ffc86adf4293d4cfb204e77d62cfe6"
-
-SRC_URI[sha256sum] = "474a2fccf7286230cf66502565f03b536921d7e1fdfceba198e42160e5ac4bc1"
-
-inherit pypi setuptools3
-
-RDEPENDS:${PN} += " \
-    python3-bitarray \
-    python3-cytoolz \
-    python3-eth-abi \
-    python3-eth-keyfile \
-    python3-eth-rlp \
-    python3-hexbytes \
-"
diff --git a/meta-python/recipes-devtools/python/python3-eth-account_0.11.0.bb b/meta-python/recipes-devtools/python/python3-eth-account_0.11.0.bb
new file mode 100644
index 000000000..84c270df6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-account_0.11.0.bb
@@ -0,0 +1,20 @@ 
+SUMMARY = "Assign Ethereum transactions and messages with local private keys."
+HOMEPAGE = "https://github.com/ethereum/eth-account"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=16ffc86adf4293d4cfb204e77d62cfe6"
+
+SRC_URI[sha256sum] = "2ffc7a0c7538053a06a7d11495c16c7ad9897dd42be0f64ca7551e9f6e0738c3"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-bitarray \
+    ${PYTHON_PN}-eth-abi \
+    ${PYTHON_PN}-eth-keyfile \
+    ${PYTHON_PN}-eth-keys \
+    ${PYTHON_PN}-eth-rlp \
+    ${PYTHON_PN}-eth-utils \
+    ${PYTHON_PN}-hexbytes \
+    ${PYTHON_PN}-rlp \
+"