diff mbox series

[meta-python] python3-moteus: add recipe for v0.3.67

Message ID 20240203230355.1837702-1-dev@g0hl1n.net
State Accepted
Headers show
Series [meta-python] python3-moteus: add recipe for v0.3.67 | expand

Commit Message

Richard Leitner Feb. 3, 2024, 11:03 p.m. UTC
moteus brushless controller library and tools. This recipe uses pypi as
source:

    https://pypi.org/project/moteus/

Signed-off-by: Richard Leitner <dev@g0hl1n.net>
---
 ...hon-remove-self-import-from-setup.py.patch | 32 +++++++++++++++++++
 .../python/python3-moteus_0.3.67.bb           | 19 +++++++++++
 2 files changed, 51 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-moteus/0001-lib-python-remove-self-import-from-setup.py.patch
 create mode 100644 meta-python/recipes-devtools/python/python3-moteus_0.3.67.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-moteus/0001-lib-python-remove-self-import-from-setup.py.patch b/meta-python/recipes-devtools/python/python3-moteus/0001-lib-python-remove-self-import-from-setup.py.patch
new file mode 100644
index 000000000..10acd7b8c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-moteus/0001-lib-python-remove-self-import-from-setup.py.patch
@@ -0,0 +1,32 @@ 
+From 7490ac4629c7fe0dc329647e6e000d4bc13c610d Mon Sep 17 00:00:00 2001
+From: Richard Leitner <dev@g0hl1n.net>
+Date: Wed, 24 Jan 2024 00:49:45 +0100
+Subject: [PATCH] lib: python: remove self-import from setup.py
+
+Importing moteus itself within the setup.py creates some kind of a
+chicken-and-egg problem. Furthermore it isn't used anywhere within
+setup.py. Therefore remove the corresponding import.
+
+Signed-off-by: Richard Leitner <dev@g0hl1n.net>
+
+Upstream-Status: Backport [https://github.com/mjbots/moteus/commit/7490ac4629c7fe0dc329647e6e000d4bc13c610d]
+---
+ setup.py | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 2731685..6c6064d 100644
+--- a/setup.py
++++ b/setup.py
+@@ -17,8 +17,6 @@
+ import setuptools
+ import pathlib
+ 
+-import moteus
+-
+ here = pathlib.Path(__file__).parent.resolve()
+ 
+ # Get the long description from the README file
+-- 
+2.40.1
+
diff --git a/meta-python/recipes-devtools/python/python3-moteus_0.3.67.bb b/meta-python/recipes-devtools/python/python3-moteus_0.3.67.bb
new file mode 100644
index 000000000..3c93ee44f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-moteus_0.3.67.bb
@@ -0,0 +1,19 @@ 
+SUMMARY = "moteus brushless controller library and tools"
+HOMEPAGE = "https://github.com/mjbots/moteus"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=3;endline=9;md5=24025d3c660abfc62a83f0e709a45e76"
+
+inherit pypi setuptools3
+
+SRC_URI += "file://0001-lib-python-remove-self-import-from-setup.py.patch"
+
+SRC_URI[sha256sum] = "a2122f20f59b8962057cf8d3fb583e0aa19006eaf2cde49e30027a4d1b8bf925"
+
+S = "${WORKDIR}/moteus-${PV}"
+
+RDEPENDS:${PN} += "\
+    python3-can \
+    python3-importlib-metadata \
+    python3-pyelftools \
+    python3-pyserial \
+"