diff mbox series

[meta-python] python3-scikit-build: upgrade 0.16.7 -> 0.17.6

Message ID 20240203211307.86988-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python] python3-scikit-build: upgrade 0.16.7 -> 0.17.6 | expand

Commit Message

Alper Ak Feb. 3, 2024, 9:13 p.m. UTC
Moved to hatchling as a build backend and requires hatch-fancy-pypi-readme, hatch-vcs. Also, added tomli as a RDEPENDS.

As stated in the upstream, the license updated to MIT only.

Changelog: https://github.com/scikit-build/scikit-build/releases

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../python/python3-scikit-build_0.16.7.bb     | 21 -----------------
 .../python/python3-scikit-build_0.17.6.bb     | 23 +++++++++++++++++++
 2 files changed, 23 insertions(+), 21 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-scikit-build_0.16.7.bb
 create mode 100644 meta-python/recipes-devtools/python/python3-scikit-build_0.17.6.bb

Comments

Tim Orling Feb. 4, 2024, 2:55 a.m. UTC | #1
On Sat, Feb 3, 2024 at 1:13 PM Alper Ak <alperyasinak1@gmail.com> wrote:

> Moved to hatchling as a build backend and requires
> hatch-fancy-pypi-readme, hatch-vcs. Also, added tomli as a RDEPENDS.


We do not actually need tomli, since Python 3.11+ has built in tomllib.
This gates it to Python 3.10 and lower:
https://github.com/scikit-build/scikit-build/blob/main/pyproject.toml#L34

(The host Python version should not matter, we use our own python3-native,
which is currently 3.12.1)

>
>
> As stated in the upstream, the license updated to MIT only.
>
> Changelog: https://github.com/scikit-build/scikit-build/releases
>
> Signed-off-by: alperak <alperyasinak1@gmail.com>
> ---
>  .../python/python3-scikit-build_0.16.7.bb     | 21 -----------------
>  .../python/python3-scikit-build_0.17.6.bb     | 23 +++++++++++++++++++
>  2 files changed, 23 insertions(+), 21 deletions(-)
>  delete mode 100644 meta-python/recipes-devtools/python/
> python3-scikit-build_0.16.7.bb
>  create mode 100644 meta-python/recipes-devtools/python/
> python3-scikit-build_0.17.6.bb
>
> diff --git a/meta-python/recipes-devtools/python/
> python3-scikit-build_0.16.7.bb b/meta-python/recipes-devtools/python/
> python3-scikit-build_0.16.7.bb
> deleted file mode 100644
> index c033c56ba..000000000
> --- a/meta-python/recipes-devtools/python/python3-scikit-build_0.16.7.bb
> +++ /dev/null
> @@ -1,21 +0,0 @@
> -SUMMARY = "Improved build system generator for Python
> C/C++/Fortran/Cython extensions"
> -LICENSE = "MIT & BSD-2-Clause"
> -LIC_FILES_CHKSUM = "file://LICENSE;md5=7c96d2b08b3cec6d3c67fb864d1fd8cc"
> -
> -DEPENDS = "python3-setuptools-scm-native"
> -
> -PYPI_PACKAGE = "scikit-build"
> -
> -inherit pypi python_setuptools_build_meta
> -SRC_URI[sha256sum] =
> "a9b9cc7479b71e6c8d434596dfade025253aae23adb22a9a2d85850fd51cecfd"
> -
> -RDEPENDS:${PN} = " \
> -       python3-distro \
> -       python3-packaging \
> -       python3-setuptools \
> -       python3-typing-extensions \
> -       python3-wheel \
> -       cmake \
> -"
> -
> -BBCLASSEXTEND = "native nativesdk"
> diff --git a/meta-python/recipes-devtools/python/
> python3-scikit-build_0.17.6.bb b/meta-python/recipes-devtools/python/
> python3-scikit-build_0.17.6.bb
> new file mode 100644
> index 000000000..8f6e40fa0
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-scikit-build_0.17.6.bb
> @@ -0,0 +1,23 @@
> +SUMMARY = "Improved build system generator for Python
> C/C++/Fortran/Cython extensions"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=7c96d2b08b3cec6d3c67fb864d1fd8cc"
> +
> +DEPENDS = "${PYTHON_PN}-hatch-vcs-native
> ${PYTHON_PN}-hatch-fancy-pypi-readme-native"
> +
> +PYPI_PACKAGE = "scikit_build"
> +
> +inherit pypi python_hatchling
> +
> +SRC_URI[sha256sum] =
> "b51a51a36b37c42650994b5047912f59b22e3210b23e321f287611f9ef6e5c9d"
> +
> +RDEPENDS:${PN} = " \
> +       ${PYTHON_PN}-distro \
> +       ${PYTHON_PN}-packaging \
> +       ${PYTHON_PN}-setuptools \
> +       ${PYTHON_PN}-tomli \
> +       ${PYTHON_PN}-typing-extensions \
> +       ${PYTHON_PN}-wheel \
> +       cmake \
> +"
> +
> +BBCLASSEXTEND = "native nativesdk"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108556):
> https://lists.openembedded.org/g/openembedded-devel/message/108556
> Mute This Topic: https://lists.openembedded.org/mt/104145984/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Alper Ak Feb. 4, 2024, 10:55 a.m. UTC | #2
Thanks for the feedback, sent patch v2.

Tim Orling <ticotimo@gmail.com>, 4 Şub 2024 Paz, 05:55 tarihinde şunu yazdı:

>
>
> On Sat, Feb 3, 2024 at 1:13 PM Alper Ak <alperyasinak1@gmail.com> wrote:
>
>> Moved to hatchling as a build backend and requires
>> hatch-fancy-pypi-readme, hatch-vcs. Also, added tomli as a RDEPENDS.
>
>
> We do not actually need tomli, since Python 3.11+ has built in tomllib.
> This gates it to Python 3.10 and lower:
> https://github.com/scikit-build/scikit-build/blob/main/pyproject.toml#L34
>
> (The host Python version should not matter, we use our own python3-native,
> which is currently 3.12.1)
>
>>
>>
>> As stated in the upstream, the license updated to MIT only.
>>
>> Changelog: https://github.com/scikit-build/scikit-build/releases
>>
>> Signed-off-by: alperak <alperyasinak1@gmail.com>
>> ---
>>  .../python/python3-scikit-build_0.16.7.bb     | 21 -----------------
>>  .../python/python3-scikit-build_0.17.6.bb     | 23 +++++++++++++++++++
>>  2 files changed, 23 insertions(+), 21 deletions(-)
>>  delete mode 100644 meta-python/recipes-devtools/python/
>> python3-scikit-build_0.16.7.bb
>>  create mode 100644 meta-python/recipes-devtools/python/
>> python3-scikit-build_0.17.6.bb
>>
>> diff --git a/meta-python/recipes-devtools/python/
>> python3-scikit-build_0.16.7.bb b/meta-python/recipes-devtools/python/
>> python3-scikit-build_0.16.7.bb
>> deleted file mode 100644
>> index c033c56ba..000000000
>> --- a/meta-python/recipes-devtools/python/python3-scikit-build_0.16.7.bb
>> +++ /dev/null
>> @@ -1,21 +0,0 @@
>> -SUMMARY = "Improved build system generator for Python
>> C/C++/Fortran/Cython extensions"
>> -LICENSE = "MIT & BSD-2-Clause"
>> -LIC_FILES_CHKSUM = "file://LICENSE;md5=7c96d2b08b3cec6d3c67fb864d1fd8cc"
>> -
>> -DEPENDS = "python3-setuptools-scm-native"
>> -
>> -PYPI_PACKAGE = "scikit-build"
>> -
>> -inherit pypi python_setuptools_build_meta
>> -SRC_URI[sha256sum] =
>> "a9b9cc7479b71e6c8d434596dfade025253aae23adb22a9a2d85850fd51cecfd"
>> -
>> -RDEPENDS:${PN} = " \
>> -       python3-distro \
>> -       python3-packaging \
>> -       python3-setuptools \
>> -       python3-typing-extensions \
>> -       python3-wheel \
>> -       cmake \
>> -"
>> -
>> -BBCLASSEXTEND = "native nativesdk"
>> diff --git a/meta-python/recipes-devtools/python/
>> python3-scikit-build_0.17.6.bb b/meta-python/recipes-devtools/python/
>> python3-scikit-build_0.17.6.bb
>> new file mode 100644
>> index 000000000..8f6e40fa0
>> --- /dev/null
>> +++ b/meta-python/recipes-devtools/python/python3-scikit-build_0.17.6.bb
>> @@ -0,0 +1,23 @@
>> +SUMMARY = "Improved build system generator for Python
>> C/C++/Fortran/Cython extensions"
>> +LICENSE = "MIT"
>> +LIC_FILES_CHKSUM = "file://LICENSE;md5=7c96d2b08b3cec6d3c67fb864d1fd8cc"
>> +
>> +DEPENDS = "${PYTHON_PN}-hatch-vcs-native
>> ${PYTHON_PN}-hatch-fancy-pypi-readme-native"
>> +
>> +PYPI_PACKAGE = "scikit_build"
>> +
>> +inherit pypi python_hatchling
>> +
>> +SRC_URI[sha256sum] =
>> "b51a51a36b37c42650994b5047912f59b22e3210b23e321f287611f9ef6e5c9d"
>> +
>> +RDEPENDS:${PN} = " \
>> +       ${PYTHON_PN}-distro \
>> +       ${PYTHON_PN}-packaging \
>> +       ${PYTHON_PN}-setuptools \
>> +       ${PYTHON_PN}-tomli \
>> +       ${PYTHON_PN}-typing-extensions \
>> +       ${PYTHON_PN}-wheel \
>> +       cmake \
>> +"
>> +
>> +BBCLASSEXTEND = "native nativesdk"
>> --
>> 2.25.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#108556):
>> https://lists.openembedded.org/g/openembedded-devel/message/108556
>> Mute This Topic: https://lists.openembedded.org/mt/104145984/924729
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
>> ticotimo@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
>>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-scikit-build_0.16.7.bb b/meta-python/recipes-devtools/python/python3-scikit-build_0.16.7.bb
deleted file mode 100644
index c033c56ba..000000000
--- a/meta-python/recipes-devtools/python/python3-scikit-build_0.16.7.bb
+++ /dev/null
@@ -1,21 +0,0 @@ 
-SUMMARY = "Improved build system generator for Python C/C++/Fortran/Cython extensions"
-LICENSE = "MIT & BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=7c96d2b08b3cec6d3c67fb864d1fd8cc"
-
-DEPENDS = "python3-setuptools-scm-native"
-
-PYPI_PACKAGE = "scikit-build"
-
-inherit pypi python_setuptools_build_meta
-SRC_URI[sha256sum] = "a9b9cc7479b71e6c8d434596dfade025253aae23adb22a9a2d85850fd51cecfd"
-
-RDEPENDS:${PN} = " \
-	python3-distro \
-	python3-packaging \
-	python3-setuptools \
-	python3-typing-extensions \
-	python3-wheel \
-	cmake \
-"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-scikit-build_0.17.6.bb b/meta-python/recipes-devtools/python/python3-scikit-build_0.17.6.bb
new file mode 100644
index 000000000..8f6e40fa0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-scikit-build_0.17.6.bb
@@ -0,0 +1,23 @@ 
+SUMMARY = "Improved build system generator for Python C/C++/Fortran/Cython extensions"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7c96d2b08b3cec6d3c67fb864d1fd8cc"
+
+DEPENDS = "${PYTHON_PN}-hatch-vcs-native ${PYTHON_PN}-hatch-fancy-pypi-readme-native"
+
+PYPI_PACKAGE = "scikit_build"
+
+inherit pypi python_hatchling
+
+SRC_URI[sha256sum] = "b51a51a36b37c42650994b5047912f59b22e3210b23e321f287611f9ef6e5c9d"
+
+RDEPENDS:${PN} = " \
+	${PYTHON_PN}-distro \
+	${PYTHON_PN}-packaging \
+	${PYTHON_PN}-setuptools \
+	${PYTHON_PN}-tomli \
+	${PYTHON_PN}-typing-extensions \
+	${PYTHON_PN}-wheel \
+	cmake \
+"
+
+BBCLASSEXTEND = "native nativesdk"