diff mbox series

[meta-oe] mdns: Fix SIGSEGV during DumpStateLog()

Message ID 20240201142028.8480-1-alex.kiernan@gmail.com
State Accepted
Headers show
Series [meta-oe] mdns: Fix SIGSEGV during DumpStateLog() | expand

Commit Message

Alex Kiernan Feb. 1, 2024, 2:20 p.m. UTC
DumpStateLog() calls LogMsgWithLevelv() with category == NULL, avoid
crashing in this case.

Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
---

 ...0001-Fix-SIGSEGV-during-DumpStateLog.patch | 30 +++++++++++++++++++
 .../mdns/mdns_2200.60.25.0.4.bb               |  1 +
 2 files changed, 31 insertions(+)
 create mode 100644 meta-networking/recipes-protocols/mdns/mdns/0001-Fix-SIGSEGV-during-DumpStateLog.patch
diff mbox series

Patch

diff --git a/meta-networking/recipes-protocols/mdns/mdns/0001-Fix-SIGSEGV-during-DumpStateLog.patch b/meta-networking/recipes-protocols/mdns/mdns/0001-Fix-SIGSEGV-during-DumpStateLog.patch
new file mode 100644
index 000000000000..4b0227f1dc38
--- /dev/null
+++ b/meta-networking/recipes-protocols/mdns/mdns/0001-Fix-SIGSEGV-during-DumpStateLog.patch
@@ -0,0 +1,30 @@ 
+From 14cc53bb09a3d8adf301f3842c765598467e63e1 Mon Sep 17 00:00:00 2001
+From: Alex Kiernan <alex.kiernan@gmail.com>
+Date: Thu, 1 Feb 2024 14:07:03 +0000
+Subject: [PATCH] Fix SIGSEGV during DumpStateLog()
+
+DumpStateLog() calls LogMsgWithLevelv() with category == NULL, avoid
+crashing in this case.
+
+Upstream-Status: Inactive-Upstream [Upstream does not take patches]
+Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
+---
+ mDNSShared/mDNSDebug.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/mDNSShared/mDNSDebug.c b/mDNSShared/mDNSDebug.c
+index 7a4ca19eff6d..d449dde320f6 100644
+--- a/mDNSShared/mDNSDebug.c
++++ b/mDNSShared/mDNSDebug.c
+@@ -71,7 +71,7 @@ mDNSlocal void LogMsgWithLevelv(os_log_t category, os_log_type_t level, const ch
+ mDNSlocal void LogMsgWithLevelv(const char *category, mDNSLogLevel_t level, const char *format, va_list args)
+ {
+     // Do not print the logs if the log category is MDNS_LOG_CATEGORY_DISABLED.
+-    if (strcmp(category, MDNS_LOG_CATEGORY_DISABLED) == 0)
++    if (category && strcmp(category, MDNS_LOG_CATEGORY_DISABLED) == 0)
+     {
+         return;
+     }
+-- 
+2.39.0
+
diff --git a/meta-networking/recipes-protocols/mdns/mdns_2200.60.25.0.4.bb b/meta-networking/recipes-protocols/mdns/mdns_2200.60.25.0.4.bb
index a009ae0c6e5c..09af3d5ae36e 100644
--- a/meta-networking/recipes-protocols/mdns/mdns_2200.60.25.0.4.bb
+++ b/meta-networking/recipes-protocols/mdns/mdns_2200.60.25.0.4.bb
@@ -24,6 +24,7 @@  SRC_URI = "git://github.com/apple-oss-distributions/mDNSResponder;protocol=https
            file://mdns.service \
            file://0015-Add-missing-limits.h.patch \
            file://0001-Handle-interface-without-ifa_addr.patch \
+           file://0001-Fix-SIGSEGV-during-DumpStateLog.patch \
            "
 SRCREV = "8acabead9ae56551011172d6835822a89c5298d6"