diff mbox series

[meta-python] python3-multidict: Fix running ptests

Message ID 20240121060635.2564856-1-raj.khem@gmail.com
State Accepted
Headers show
Series [meta-python] python3-multidict: Fix running ptests | expand

Commit Message

Khem Raj Jan. 21, 2024, 6:06 a.m. UTC
Add missing runtime dependency on pytest-cov
and move the test to PTESTS_FAST_META_PYTHON since it takes < 20 seconds

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-python/conf/include/ptest-packagelists-meta-python.inc    | 2 +-
 .../recipes-devtools/python/python3-multidict/run-ptest        | 3 +--
 meta-python/recipes-devtools/python/python3-multidict_6.0.4.bb | 1 +
 3 files changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 2c75d511b3..44507b394e 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -22,6 +22,7 @@  PTESTS_FAST_META_PYTHON = "\
     python3-intervals \
     python3-ipy \
     python3-iso3166 \
+    python3-multidict \
     python3-parse-type \
     python3-platformdirs \
     python3-polyline \
@@ -71,7 +72,6 @@  PTESTS_PROBLEMS_META_PYTHON ="\
     python3-jsmin \
     python3-license-expression \
     python3-msgpack \
-    python3-multidict \
     python3-ordered-set \
     python3-parse \
     python3-pillow \
diff --git a/meta-python/recipes-devtools/python/python3-multidict/run-ptest b/meta-python/recipes-devtools/python/python3-multidict/run-ptest
index 5cec711696..e4f3b623ab 100644
--- a/meta-python/recipes-devtools/python/python3-multidict/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-multidict/run-ptest
@@ -1,3 +1,2 @@ 
 #!/bin/sh
-
-pytest
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-multidict_6.0.4.bb b/meta-python/recipes-devtools/python/python3-multidict_6.0.4.bb
index 23d3eb3155..b057e05f65 100644
--- a/meta-python/recipes-devtools/python/python3-multidict_6.0.4.bb
+++ b/meta-python/recipes-devtools/python/python3-multidict_6.0.4.bb
@@ -19,6 +19,7 @@  SRC_URI += " \
 
 RDEPENDS:${PN}-ptest += " \
 	${PYTHON_PN}-pytest \
+	${PYTHON_PN}-pytest-cov \
 "
 
 do_install_ptest() {