diff mbox series

[meta-python,1/2] python3-coverage: add native and nativesdk BBCLASSEXTEND

Message ID 20240118164959.2797172-1-yoann.congal@smile.fr
State Accepted
Headers show
Series [meta-python,1/2] python3-coverage: add native and nativesdk BBCLASSEXTEND | expand

Commit Message

Yoann Congal Jan. 18, 2024, 4:49 p.m. UTC
To build python3-pytest-cov-native we need python3-coverage-native.
To build nativesdk-python3-pytest-cov we need nativesdk-python3-coverage.

Signed-off-by: Yoann Congal <yoann.congal@smile.fr>

---
Tested in native and nativesdk environnement:
"pytest --cov" does exist and start.
---
 meta-python/recipes-devtools/python/python3-coverage_7.4.0.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-coverage_7.4.0.bb b/meta-python/recipes-devtools/python/python3-coverage_7.4.0.bb
index cb1041c2f..30922697a 100644
--- a/meta-python/recipes-devtools/python/python3-coverage_7.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-coverage_7.4.0.bb
@@ -18,3 +18,5 @@  RDEPENDS:${PN} += " \
     python3-tomllib \
     python3-xml \
 "
+
+BBCLASSEXTEND = "native nativesdk"