diff mbox series

[meta-oe] open-cl: stop using "virtual/" in RPROVIDES

Message ID 20240117202405.29013-1-simone.p.weiss@posteo.com
State Superseded
Headers show
Series [meta-oe] open-cl: stop using "virtual/" in RPROVIDES | expand

Commit Message

Simone Weiß Jan. 17, 2024, 8:24 p.m. UTC
From: Simone Weiß <simone.p.weiss@posteo.com>

For RPROVIDES and RDEPENDS the string "/virtual" holds no special meaning
and hence packages should avoid the use of "virtual/" there. Update it
for opencl to the suggested alternative "-virtual". See also the
discussion on the yocto docs mailing list:
https://lists.yoctoproject.org/g/docs/message/1785

Signed-off-by: Simone Weiß <simone.p.weiss@posteo.com>
---
 meta-oe/recipes-core/opencl/ocl-icd_2.3.2.bb                | 2 +-
 meta-oe/recipes-core/opencl/opencl-icd-loader_2023.12.14.bb | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Khem Raj Jan. 18, 2024, 4:51 p.m. UTC | #1
I have staged a similar patch already in master-next
https://patchwork.yoctoproject.org/project/oe/patch/20240116235052.3713167-1-raj.khem@gmail.com/

On Wed, Jan 17, 2024 at 12:24 PM Simone Weiß <simone.p.weiss@posteo.com> wrote:
>
> From: Simone Weiß <simone.p.weiss@posteo.com>
>
> For RPROVIDES and RDEPENDS the string "/virtual" holds no special meaning
> and hence packages should avoid the use of "virtual/" there. Update it
> for opencl to the suggested alternative "-virtual". See also the
> discussion on the yocto docs mailing list:
> https://lists.yoctoproject.org/g/docs/message/1785
>
> Signed-off-by: Simone Weiß <simone.p.weiss@posteo.com>
> ---
>  meta-oe/recipes-core/opencl/ocl-icd_2.3.2.bb                | 2 +-
>  meta-oe/recipes-core/opencl/opencl-icd-loader_2023.12.14.bb | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/meta-oe/recipes-core/opencl/ocl-icd_2.3.2.bb b/meta-oe/recipes-core/opencl/ocl-icd_2.3.2.bb
> index 93fac969c..d43ea281a 100644
> --- a/meta-oe/recipes-core/opencl/ocl-icd_2.3.2.bb
> +++ b/meta-oe/recipes-core/opencl/ocl-icd_2.3.2.bb
> @@ -15,6 +15,6 @@ inherit autotools
>
>  DEPENDS = "ruby-native"
>  PROVIDES = "virtual/opencl-icd"
> -RPROVIDES:${PN} = "virtual/opencl-icd"
> +RPROVIDES:${PN} = "virtual-opencl-icd"
>
>  BBCLASSEXTEND = "native nativesdk"
> diff --git a/meta-oe/recipes-core/opencl/opencl-icd-loader_2023.12.14.bb b/meta-oe/recipes-core/opencl/opencl-icd-loader_2023.12.14.bb
> index 6bf01a248..146ec6e47 100644
> --- a/meta-oe/recipes-core/opencl/opencl-icd-loader_2023.12.14.bb
> +++ b/meta-oe/recipes-core/opencl/opencl-icd-loader_2023.12.14.bb
> @@ -9,7 +9,7 @@ inherit pkgconfig cmake
>  DEPENDS += "opencl-headers"
>
>  PROVIDES = "virtual/opencl-icd"
> -RPROVIDES:${PN} = "virtual/opencl-icd"
> +RPROVIDES:${PN} = "virtual-opencl-icd"
>
>  S = "${WORKDIR}/git"
>
> --
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108339): https://lists.openembedded.org/g/openembedded-devel/message/108339
> Mute This Topic: https://lists.openembedded.org/mt/103794862/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-core/opencl/ocl-icd_2.3.2.bb b/meta-oe/recipes-core/opencl/ocl-icd_2.3.2.bb
index 93fac969c..d43ea281a 100644
--- a/meta-oe/recipes-core/opencl/ocl-icd_2.3.2.bb
+++ b/meta-oe/recipes-core/opencl/ocl-icd_2.3.2.bb
@@ -15,6 +15,6 @@  inherit autotools
 
 DEPENDS = "ruby-native"
 PROVIDES = "virtual/opencl-icd"
-RPROVIDES:${PN} = "virtual/opencl-icd"
+RPROVIDES:${PN} = "virtual-opencl-icd"
 
 BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-core/opencl/opencl-icd-loader_2023.12.14.bb b/meta-oe/recipes-core/opencl/opencl-icd-loader_2023.12.14.bb
index 6bf01a248..146ec6e47 100644
--- a/meta-oe/recipes-core/opencl/opencl-icd-loader_2023.12.14.bb
+++ b/meta-oe/recipes-core/opencl/opencl-icd-loader_2023.12.14.bb
@@ -9,7 +9,7 @@  inherit pkgconfig cmake
 DEPENDS += "opencl-headers"
 
 PROVIDES = "virtual/opencl-icd"
-RPROVIDES:${PN} = "virtual/opencl-icd"
+RPROVIDES:${PN} = "virtual-opencl-icd"
 
 S = "${WORKDIR}/git"