diff mbox series

[meta-python] python3-pytest-cov: Remove unbuildable BBCLASSEXTENDs

Message ID 20240117082519.3037503-1-yoann.congal@smile.fr
State Superseded
Headers show
Series [meta-python] python3-pytest-cov: Remove unbuildable BBCLASSEXTENDs | expand

Commit Message

Yoann Congal Jan. 17, 2024, 8:25 a.m. UTC
Since the python3-coverage dependency has neither native nor nativesdk
BBCLASSEXTEND, remove these to avoid triggering warnings on universe
builds.

Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
---
CC: Richard Leitner <dev@g0hl1n.net>
This is related to this ML thread: https://lists.openembedded.org/g/openembedded-devel/topic/103499188#108305
---
 meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb | 2 --
 1 file changed, 2 deletions(-)

Comments

Khem Raj Jan. 17, 2024, 3:26 p.m. UTC | #1
how about we add

BBCLASSEXTEND = "native nativesdk"

to meta-python/recipes-devtools/python/python3-coverage_7.4.0.bb

On Wed, Jan 17, 2024 at 12:26 AM Yoann Congal <yoann.congal@smile.fr> wrote:
>
> Since the python3-coverage dependency has neither native nor nativesdk
> BBCLASSEXTEND, remove these to avoid triggering warnings on universe
> builds.
>
> Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
> ---
> CC: Richard Leitner <dev@g0hl1n.net>
> This is related to this ML thread: https://lists.openembedded.org/g/openembedded-devel/topic/103499188#108305
> ---
>  meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb | 2 --
>  1 file changed, 2 deletions(-)
>
> diff --git a/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb b/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
> index 3a68011f4..2591539ec 100644
> --- a/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
> +++ b/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
> @@ -11,5 +11,3 @@ inherit pypi setuptools3
>
>  DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
>  RDEPENDS:${PN} += "python3-coverage"
> -
> -BBCLASSEXTEND = "native nativesdk"
> --
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108324): https://lists.openembedded.org/g/openembedded-devel/message/108324
> Mute This Topic: https://lists.openembedded.org/mt/103782092/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Yoann Congal Jan. 17, 2024, 4:20 p.m. UTC | #2
Le mer. 17 janv. 2024 à 16:26, Khem Raj <raj.khem@gmail.com> a écrit :

> how about we add
>
> BBCLASSEXTEND = "native nativesdk"
>
> to meta-python/recipes-devtools/python/python3-coverage_7.4.0.bb


Sure! ... But I have no idea how to test it.
Do we really care about pytest-cov in native environments? If yes, I'll
look into it.


On Wed, Jan 17, 2024 at 12:26 AM Yoann Congal <yoann.congal@smile.fr> wrote:
> >
> > Since the python3-coverage dependency has neither native nor nativesdk
> > BBCLASSEXTEND, remove these to avoid triggering warnings on universe
> > builds.
> >
> > Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
> > ---
> > CC: Richard Leitner <dev@g0hl1n.net>
> > This is related to this ML thread:
> https://lists.openembedded.org/g/openembedded-devel/topic/103499188#108305
> > ---
> >  meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb | 2 --
> >  1 file changed, 2 deletions(-)
> >
> > diff --git a/meta-python/recipes-devtools/python/
> python3-pytest-cov_4.1.0.bb b/meta-python/recipes-devtools/python/
> python3-pytest-cov_4.1.0.bb
> > index 3a68011f4..2591539ec 100644
> > --- a/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
> > +++ b/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
> > @@ -11,5 +11,3 @@ inherit pypi setuptools3
> >
> >  DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
> >  RDEPENDS:${PN} += "python3-coverage"
> > -
> > -BBCLASSEXTEND = "native nativesdk"
> > --
> > 2.39.2
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#108324):
> https://lists.openembedded.org/g/openembedded-devel/message/108324
> > Mute This Topic: https://lists.openembedded.org/mt/103782092/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >


--
Yoann Congal - Smile ECS

>
Khem Raj Jan. 17, 2024, 4:31 p.m. UTC | #3
On Wed, Jan 17, 2024 at 8:20 AM Yoann CONGAL <yoann.congal@smile.fr> wrote:

> Le mer. 17 janv. 2024 à 16:26, Khem Raj <raj.khem@gmail.com> a écrit :
>
>> how about we add
>>
>> BBCLASSEXTEND = "native nativesdk"
>>
>> to meta-python/recipes-devtools/python/python3-coverage_7.4.0.bb
>
>
> Sure! ... But I have no idea how to test it.
> Do we really care about pytest-cov in native environments? If yes, I'll
> look into it.
>

Since the native extends existed before it gained the extra dependency on
coverage package it’s possible that there is a use of it already in place

>
>
> On Wed, Jan 17, 2024 at 12:26 AM Yoann Congal <yoann.congal@smile.fr>
>> wrote:
>> >
>> > Since the python3-coverage dependency has neither native nor nativesdk
>> > BBCLASSEXTEND, remove these to avoid triggering warnings on universe
>> > builds.
>> >
>> > Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
>> > ---
>> > CC: Richard Leitner <dev@g0hl1n.net>
>> > This is related to this ML thread:
>> https://lists.openembedded.org/g/openembedded-devel/topic/103499188#108305
>> > ---
>> >  meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb | 2 --
>> >  1 file changed, 2 deletions(-)
>> >
>> > diff --git a/meta-python/recipes-devtools/python/
>> python3-pytest-cov_4.1.0.bb b/meta-python/recipes-devtools/python/
>> python3-pytest-cov_4.1.0.bb
>> > index 3a68011f4..2591539ec 100644
>> > --- a/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
>> > +++ b/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
>> > @@ -11,5 +11,3 @@ inherit pypi setuptools3
>> >
>> >  DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
>> >  RDEPENDS:${PN} += "python3-coverage"
>> > -
>> > -BBCLASSEXTEND = "native nativesdk"
>> > --
>> > 2.39.2
>> >
>> >
>> > -=-=-=-=-=-=-=-=-=-=-=-
>> > Links: You receive all messages sent to this group.
>> > View/Reply Online (#108324):
>> https://lists.openembedded.org/g/openembedded-devel/message/108324
>> > Mute This Topic: https://lists.openembedded.org/mt/103782092/1997914
>> > Group Owner: openembedded-devel+owner@lists.openembedded.org
>> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub
>> [raj.khem@gmail.com]
>> > -=-=-=-=-=-=-=-=-=-=-=-
>> >
>
>
> --
> Yoann Congal - Smile ECS
>
>>
Yoann Congal Jan. 17, 2024, 4:44 p.m. UTC | #4
Le mer. 17 janv. 2024 à 17:31, Khem Raj <raj.khem@gmail.com> a écrit :

>
>
> On Wed, Jan 17, 2024 at 8:20 AM Yoann CONGAL <yoann.congal@smile.fr>
> wrote:
>
>> Le mer. 17 janv. 2024 à 16:26, Khem Raj <raj.khem@gmail.com> a écrit :
>>
>>> how about we add
>>>
>>> BBCLASSEXTEND = "native nativesdk"
>>>
>>> to meta-python/recipes-devtools/python/python3-coverage_7.4.0.bb
>>
>>
>> Sure! ... But I have no idea how to test it.
>> Do we really care about pytest-cov in native environments? If yes, I'll
>> look into it.
>>
>
> Since the native extends existed before it gained the extra dependency on
> coverage package it’s possible that there is a use of it already in place
>

Good point. I'll try test it before sending a patch.


>> On Wed, Jan 17, 2024 at 12:26 AM Yoann Congal <yoann.congal@smile.fr>
>>> wrote:
>>> >
>>> > Since the python3-coverage dependency has neither native nor nativesdk
>>> > BBCLASSEXTEND, remove these to avoid triggering warnings on universe
>>> > builds.
>>> >
>>> > Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
>>> > ---
>>> > CC: Richard Leitner <dev@g0hl1n.net>
>>> > This is related to this ML thread:
>>> https://lists.openembedded.org/g/openembedded-devel/topic/103499188#108305
>>> > ---
>>> >  meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb | 2
>>> --
>>> >  1 file changed, 2 deletions(-)
>>> >
>>> > diff --git a/meta-python/recipes-devtools/python/
>>> python3-pytest-cov_4.1.0.bb b/meta-python/recipes-devtools/python/
>>> python3-pytest-cov_4.1.0.bb
>>> > index 3a68011f4..2591539ec 100644
>>> > --- a/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
>>> > +++ b/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
>>> > @@ -11,5 +11,3 @@ inherit pypi setuptools3
>>> >
>>> >  DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
>>> >  RDEPENDS:${PN} += "python3-coverage"
>>> > -
>>> > -BBCLASSEXTEND = "native nativesdk"
>>> > --
>>> > 2.39.2
>>> >
>>> >
>>> > -=-=-=-=-=-=-=-=-=-=-=-
>>> > Links: You receive all messages sent to this group.
>>> > View/Reply Online (#108324):
>>> https://lists.openembedded.org/g/openembedded-devel/message/108324
>>> > Mute This Topic: https://lists.openembedded.org/mt/103782092/1997914
>>> > Group Owner: openembedded-devel+owner@lists.openembedded.org
>>> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub
>>> [raj.khem@gmail.com]
>>> > -=-=-=-=-=-=-=-=-=-=-=-
>>> >
>>
>>
>> --
>> Yoann Congal - Smile ECS
>>
>>>
Yoann Congal Jan. 18, 2024, 4:58 p.m. UTC | #5
Le mer. 17 janv. 2024 à 17:44, Yoann CONGAL <yoann.congal@smile.fr> a
écrit :

> Le mer. 17 janv. 2024 à 17:31, Khem Raj <raj.khem@gmail.com> a écrit :
>
>> On Wed, Jan 17, 2024 at 8:20 AM Yoann CONGAL <yoann.congal@smile.fr>
>> wrote:
>>
>>> Le mer. 17 janv. 2024 à 16:26, Khem Raj <raj.khem@gmail.com> a écrit :
>>>
>>>> how about we add
>>>>
>>>> BBCLASSEXTEND = "native nativesdk"
>>>>
>>>> to meta-python/recipes-devtools/python/python3-coverage_7.4.0.bb
>>>
>>>
>>> Sure! ... But I have no idea how to test it.
>>> Do we really care about pytest-cov in native environments? If yes, I'll
>>> look into it.
>>>
>>
>> Since the native extends existed before it gained the extra dependency on
>> coverage package it’s possible that there is a use of it already in place
>>
>
> Good point. I'll try test it before sending a patch.
>

Patches sent here:
[meta-python][PATCH 1/2] python3-coverage: add native and nativesdk
BBCLASSEXTEND
https://lists.openembedded.org/g/openembedded-devel/message/108346
[meta-python][PATCH 2/2] python3-pytest-cov: Add missing python3-pytest
RDEPENDS
https://lists.openembedded.org/g/openembedded-devel/message/108347
Khem Raj Jan. 18, 2024, 5 p.m. UTC | #6
On Thu, Jan 18, 2024 at 8:59 AM Yoann CONGAL <yoann.congal@smile.fr> wrote:
>
>
>
> Le mer. 17 janv. 2024 à 17:44, Yoann CONGAL <yoann.congal@smile.fr> a écrit :
>>
>> Le mer. 17 janv. 2024 à 17:31, Khem Raj <raj.khem@gmail.com> a écrit :
>>>
>>> On Wed, Jan 17, 2024 at 8:20 AM Yoann CONGAL <yoann.congal@smile.fr> wrote:
>>>>
>>>> Le mer. 17 janv. 2024 à 16:26, Khem Raj <raj.khem@gmail.com> a écrit :
>>>>>
>>>>> how about we add
>>>>>
>>>>> BBCLASSEXTEND = "native nativesdk"
>>>>>
>>>>> to meta-python/recipes-devtools/python/python3-coverage_7.4.0.bb
>>>>
>>>>
>>>> Sure! ... But I have no idea how to test it.
>>>> Do we really care about pytest-cov in native environments? If yes, I'll look into it.
>>>
>>>
>>> Since the native extends existed before it gained the extra dependency on coverage package it’s possible that there is a use of it already in place
>>
>>
>> Good point. I'll try test it before sending a patch.
>
>
> Patches sent here:
> [meta-python][PATCH 1/2] python3-coverage: add native and nativesdk BBCLASSEXTEND
> https://lists.openembedded.org/g/openembedded-devel/message/108346
> [meta-python][PATCH 2/2] python3-pytest-cov: Add missing python3-pytest RDEPENDS
> https://lists.openembedded.org/g/openembedded-devel/message/108347
>

Looks good, thanks.

> --
> Yoann Congal
> Smile ECS - Tech expert
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb b/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
index 3a68011f4..2591539ec 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-cov_4.1.0.bb
@@ -11,5 +11,3 @@  inherit pypi setuptools3
 
 DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
 RDEPENDS:${PN} += "python3-coverage"
-
-BBCLASSEXTEND = "native nativesdk"