diff mbox series

[2/5] glade: inherit gtk-doc, fix FILES

Message ID 20240112182736.3448071-2-ross.burton@arm.com
State Accepted
Headers show
Series [1/5] telepathy-glib: inherit gtk-doc | expand

Commit Message

Ross Burton Jan. 12, 2024, 6:27 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

Recent changes to oe-core[1] mean that if a configure.ac uses gtk-doc
then gtkdocize will be called. This means that recipes that don't
inherit gtk-doc (to depend on gtk-doc-native) but don't explicitly
disable the use of gtkdocize will fail to configure.

Inheriting gtk-doc both solves the configure failure, and allows us to
build the API documentation.

Also, clean up FILES:

Don't package all of ${datadir} in PN, as this means the locale
information isn't split into the appropriate packages.

.la files are deleted globally so there's no need to package them in
PN-dev.

Debug files are managed automatically so there's no need to package them
at all.

[1] oe-core 891ec38d4c5cc5ac7bc34938276261ebd6f6d54e

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta-oe/recipes-devtools/glade/glade_3.22.2.bb | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/glade/glade_3.22.2.bb b/meta-oe/recipes-devtools/glade/glade_3.22.2.bb
index 3936e04c6d..d11751a4b2 100644
--- a/meta-oe/recipes-devtools/glade/glade_3.22.2.bb
+++ b/meta-oe/recipes-devtools/glade/glade_3.22.2.bb
@@ -9,7 +9,7 @@  DEPENDS = "gtk+3 glib-2.0 libxml2 intltool-native \
            autoconf-archive-native \
 "
 GNOMEBASEBUILDCLASS = "autotools"
-inherit features_check autotools pkgconfig gnomebase gobject-introspection mime-xdg
+inherit features_check autotools pkgconfig gnomebase gobject-introspection mime-xdg gtk-doc
 
 # xfce4 depends on libwnck3, gtk+3 and libepoxy need to be built with x11 PACKAGECONFIG.
 # cairo would at least needed to be built with xlib.
@@ -23,7 +23,4 @@  SRC_URI[sha256sum] = "edefa6eb24b4d15bd52589121dc109bc08c286157c41288deb74dd9cc3
 
 EXTRA_OECONF += "--disable-man-pages"
 
-FILES:${PN} += "${datadir}/* ${libdir}/glade/modules/libgladegtk.so"
-FILES:${PN}-dev += "${libdir}/glade/modules/libgladegtk.la"
-FILES:${PN}-dbg += "${libdir}/glade/modules/.debug/libgladegtk.so"
-
+FILES:${PN} += "${datadir}/glade ${datadir}/metainfo ${libdir}/glade/modules/libgladegtk.so"