diff mbox series

[3/4] gtksourceview4: remove check for target gtk-doc

Message ID 20240112125340.495067-3-ross.burton@arm.com
State Accepted
Headers show
Series [1/4] libuser: fix gtk-doc configure call | expand

Commit Message

Ross Burton Jan. 12, 2024, 12:53 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

Packages that use gtk-doc want to find a native gtk-doc not a target
gtk-doc, so remove the pointless check for a target gtk-doc package.

This only worked before as it was being pulled in via DEPENDS in
glib-2.0, but as of oe-core f91694f this no longer happens.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../files/0001-remove-pointless-check.patch   | 38 +++++++++++++++++++
 .../gtksourceview/gtksourceview4_4.8.4.bb     |  4 +-
 2 files changed, 40 insertions(+), 2 deletions(-)
 create mode 100644 meta-gnome/recipes-gnome/gtksourceview/files/0001-remove-pointless-check.patch
diff mbox series

Patch

diff --git a/meta-gnome/recipes-gnome/gtksourceview/files/0001-remove-pointless-check.patch b/meta-gnome/recipes-gnome/gtksourceview/files/0001-remove-pointless-check.patch
new file mode 100644
index 0000000000..8230bbbd16
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gtksourceview/files/0001-remove-pointless-check.patch
@@ -0,0 +1,38 @@ 
+From 397751846130f79d5fbe8d617b788f3bcbb36816 Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@arm.com>
+Date: Tue, 9 Jan 2024 22:20:03 +0000
+Subject: [PATCH] meson: remove pointless gtk-doc check
+
+There's no point explicitly checking for gtk-doc, for two reasons:
+
+1) In cross-compiled environments this looks for a target gtk-doc, not a
+   native gtk-doc, so it should set native:true.
+
+2) The gnome.gtkdoc() function checks for gtk-doc itself.
+
+Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/gtksourceview/-/merge_requests/351]
+Signed-off-by: Ross Burton <ross.burton@arm.com>
+---
+ meson.build | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index ba07da70..1109daea 100644
+--- a/meson.build
++++ b/meson.build
+@@ -107,12 +107,6 @@ else
+   vapigen_dep = []
+ endif
+ 
+-if build_gtk_doc
+-  gtk_doc_dep = dependency('gtk-doc', version: gtk_doc_req)
+-else
+-  gtk_doc_dep = []
+-endif
+-
+ # Look for the libxml2 library manually on Visual Studio if
+ # its pkg-config file could not be found, as the NMake
+ # Makefiles of libxml2 do not generate the pkg-config files
+-- 
+2.34.1
+
diff --git a/meta-gnome/recipes-gnome/gtksourceview/gtksourceview4_4.8.4.bb b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview4_4.8.4.bb
index 353f02f1ba..5d7d02a2c9 100644
--- a/meta-gnome/recipes-gnome/gtksourceview/gtksourceview4_4.8.4.bb
+++ b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview4_4.8.4.bb
@@ -10,12 +10,12 @@  PNAME = "gtksourceview"
 
 S = "${WORKDIR}/${PNAME}-${PV}"
 
-
 inherit gnomebase lib_package gettext features_check gtk-doc gobject-introspection vala
 
 ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
 
-SRC_URI = "https://download.gnome.org/sources/gtksourceview/4.8/${PNAME}-${PV}.tar.xz"
+SRC_URI = "https://download.gnome.org/sources/gtksourceview/4.8/${PNAME}-${PV}.tar.xz \
+           file://0001-remove-pointless-check.patch"
 SRC_URI[sha256sum] = "7ec9d18fb283d1f84a3a3eff3b7a72b09a10c9c006597b3fbabbb5958420a87d"
 
 GIR_MESON_OPTION = 'gir'