diff mbox series

[meta-oe] libnvme: upgrade 1.6 -> 1.7.1

Message ID 20240101154519.540245-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-oe] libnvme: upgrade 1.6 -> 1.7.1 | expand

Commit Message

Alper Ak Jan. 1, 2024, 3:45 p.m. UTC
* Patch dropped because it is already available in the new version.

Changelog:

====== 1.7.1 ======

* The v1.7 contains a bug in the sysfs scan topology code which could double free some memory. As this is a very common code path to execute, it's worth to get this fix out fast.

======= 1.7 =======

* allocated payloads aligned
* refactoring and improvements of RAE handling in get log pages
* auto cleanup of resources
* build instruction update and improving build situation for older distros
* support for TP8018
* use sysfs only for topology scan

The last point addresses a long standing problem. Whenever 'nvme list' is used it could add error log entries for certain devices. With the corresponding kernel changes this will not happen anymore. It also unlocks some possible new features. Note this depends on the upcoming 6.8 kernel.

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 ...01-test-handle-POSIX-ioctl-prototype.patch | 68 -------------------
 .../{libnvme_1.6.bb => libnvme_1.7.1.bb}      |  6 +-
 2 files changed, 2 insertions(+), 72 deletions(-)
 delete mode 100644 meta-oe/recipes-support/libnvme/libnvme/0001-test-handle-POSIX-ioctl-prototype.patch
 rename meta-oe/recipes-support/libnvme/{libnvme_1.6.bb => libnvme_1.7.1.bb} (86%)

Comments

Khem Raj Jan. 8, 2024, 2:46 a.m. UTC | #1
On Mon, 01 Jan 2024 18:45:19 +0300, alperak wrote:
> * Patch dropped because it is already available in the new version.
> 
> Changelog:
> 
> ====== 1.7.1 ======
> 
> * The v1.7 contains a bug in the sysfs scan topology code which could double free some memory. As this is a very common code path to execute, it's worth to get this fix out fast.
> 
> [...]

Applied, thanks!

[1/1] libnvme: upgrade 1.6 -> 1.7.1
      commit: 7a6ca59ab1f57974066a377677bb3c41908ceaa1

Best regards,
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/libnvme/libnvme/0001-test-handle-POSIX-ioctl-prototype.patch b/meta-oe/recipes-support/libnvme/libnvme/0001-test-handle-POSIX-ioctl-prototype.patch
deleted file mode 100644
index ef9cc47d2..000000000
--- a/meta-oe/recipes-support/libnvme/libnvme/0001-test-handle-POSIX-ioctl-prototype.patch
+++ /dev/null
@@ -1,68 +0,0 @@ 
-From ca47ba3119365eafac0ab25a86cab9d9a1b29bd4 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Sat, 30 Sep 2023 06:38:53 +0100
-Subject: [PATCH] test: handle POSIX ioctl prototype
-
-glibc has the following prototype for ioctl: int ioctl(int fd, unsigned long request, ...)
-POSIX (inc. musl) has the following for ioctl: int ioctl(int fd, int request, ...)
-
-Check which prototype is used in <sys/ioctl.h> to avoid a conflict and conditionally
-define the right one for the system.
-
-Bug: https://bugs.gentoo.org/914921
-Signed-off-by: Sam James <sam@gentoo.org>
-Upstream-Status: Backport [https://github.com/linux-nvme/libnvme/commit/ca47ba3119365eafac0ab25a86cab9d9a1b29bd4]
----
- meson.build       | 10 ++++++++++
- test/ioctl/mock.c |  6 +++++-
- 2 files changed, 15 insertions(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index 6fcf1da..2c979cc 100644
---- a/meson.build
-+++ b/meson.build
-@@ -230,6 +230,16 @@ conf.set(
-     ),
-     description: 'Is network address and service translation available'
- )
-+conf.set(
-+    'HAVE_GLIBC_IOCTL',
-+    cc.compiles(
-+        '''#include <sys/ioctl.h>
-+        int ioctl(int fd, unsigned long request, ...);
-+        ''',
-+        name: 'ioctl has glibc-style prototype'
-+    ),
-+    description: 'Is ioctl the glibc interface (rather than POSIX)'
-+)
- 
- if cc.has_function_attribute('fallthrough')
-   conf.set('fallthrough', '__attribute__((__fallthrough__))')
-diff --git a/test/ioctl/mock.c b/test/ioctl/mock.c
-index e917244..5d2ac94 100644
---- a/test/ioctl/mock.c
-+++ b/test/ioctl/mock.c
-@@ -114,7 +114,11 @@ void end_mock_cmds(void)
- 	} \
- })
- 
-+#ifdef HAVE_GLIBC_IOCTL
- int ioctl(int fd, unsigned long request, ...)
-+#else
-+int ioctl(int fd, int request, ...)
-+#endif
- {
- 	struct mock_cmds *mock_cmds;
- 	bool result64;
-@@ -141,7 +145,7 @@ int ioctl(int fd, unsigned long request, ...)
- 		result64 = true;
- 		break;
- 	default:
--		fail("unexpected %s %lu", __func__, request);
-+		fail("unexpected %s %lu", __func__, (unsigned long) request);
- 	}
- 	check(mock_cmds->remaining_cmds,
- 	      "unexpected %s command", mock_cmds->name);
--- 
-2.40.1
-
diff --git a/meta-oe/recipes-support/libnvme/libnvme_1.6.bb b/meta-oe/recipes-support/libnvme/libnvme_1.7.1.bb
similarity index 86%
rename from meta-oe/recipes-support/libnvme/libnvme_1.6.bb
rename to meta-oe/recipes-support/libnvme/libnvme_1.7.1.bb
index 802edac50..985fd7c55 100644
--- a/meta-oe/recipes-support/libnvme/libnvme_1.6.bb
+++ b/meta-oe/recipes-support/libnvme/libnvme_1.7.1.bb
@@ -11,11 +11,9 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
                     file://ccan/licenses/CC0;md5=c17af43b05840255a6fedc5eda9d56cc \
                     file://ccan/licenses/BSD-MIT;md5=838c366f69b72c5df05c96dff79b35f2"
 DEPENDS = "json-c"
-SRCREV = "37a803cf77e224f66d86b1e1d9e74a15f55ea600"
+SRCREV = "13ba38387e5446849ae59d3ccd8183cf9aca3145"
 
-SRC_URI = "git://github.com/linux-nvme/libnvme;protocol=https;branch=master \
-           file://0001-test-handle-POSIX-ioctl-prototype.patch \
-"
+SRC_URI = "git://github.com/linux-nvme/libnvme;protocol=https;branch=master"
 
 S = "${WORKDIR}/git"