diff mbox series

[18/23] mongodb: skip until python 3.12 fixes are available.

Message ID 20231231122329.405225-18-alex@linutronix.de
State Accepted
Headers show
Series [01/23] fontforge: add a readline PACKAGECONFIG | expand

Commit Message

Alexander Kanavin Dec. 31, 2023, 12:23 p.m. UTC
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 .../meta-python/recipes-dbs/mongodb/mongodb_git.bb              | 2 ++
 1 file changed, 2 insertions(+)

Comments

Joao Marcos Costa Jan. 16, 2024, 9:24 a.m. UTC | #1
Hello Alexander,

On 12/31/23 13:23, Alexander Kanavin wrote:
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ---
>   .../meta-python/recipes-dbs/mongodb/mongodb_git.bb              | 2 ++
>   1 file changed, 2 insertions(+)
>
> diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
> index 037d58cf1..ee5c77a85 100644
> --- a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
> +++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
> @@ -145,3 +145,5 @@ SYSTEMD_SERVICE:${PN} = "mongod.service"
>   FILES:${PN} += "${nonarch_libdir}/tmpfiles.d"
>   
>   RDEPENDS:${PN} += "tzdata-core"
> +
> +SKIP_RECIPE[mongodb] ?= "Needs porting to python 3.12"


Would you have any updates on this porting?

As of now, skipping mongodb is raising some warnings in YP Autobuilder:

https://autobuilder.yoctoproject.org/typhoon/#/builders/156/builds/206/steps/12/logs/warnings

and 
https://autobuilder.yoctoproject.org/typhoon/#/builders/156/builds/193/steps/12/logs/warnings
Alexander Kanavin Jan. 16, 2024, 9:30 a.m. UTC | #2
On Tue, 16 Jan 2024 at 10:24, Joao Marcos Costa
<joaomarcos.costa@bootlin.com> wrote:
> Would you have any updates on this porting?

I wouldn't and I don't plan to fix it. Mongodb is under a proprietary
license that OSI rejected and thus in my opinion doesn't belong in
meta-oe at all.

If it's important to you, then you need to do the work.

Alex
Yoann Congal Jan. 16, 2024, 5:13 p.m. UTC | #3
Hello,

Le 16/01/2024 à 10:30, Alexander Kanavin a écrit :
> On Tue, 16 Jan 2024 at 10:24, Joao Marcos Costa
> <joaomarcos.costa@bootlin.com> wrote:
>> Would you have any updates on this porting?
> 
> I wouldn't and I don't plan to fix it. Mongodb is under a proprietary
> license that OSI rejected and thus in my opinion doesn't belong in
> meta-oe at all.
> 
> If it's important to you, then you need to do the work.

FYI, I've sent a patch removing mongodb from the packagegroup:
https://lists.openembedded.org/g/openembedded-devel/message/108306

Regards,
diff mbox series

Patch

diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
index 037d58cf1..ee5c77a85 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
@@ -145,3 +145,5 @@  SYSTEMD_SERVICE:${PN} = "mongod.service"
 FILES:${PN} += "${nonarch_libdir}/tmpfiles.d"
 
 RDEPENDS:${PN} += "tzdata-core"
+
+SKIP_RECIPE[mongodb] ?= "Needs porting to python 3.12"