diff mbox series

[meta-oe] epeg: upgrade to latest release(0.9.3)

Message ID 20231223073501.49038-1-alperyasinak1@gmail.com
State New
Headers show
Series [meta-oe] epeg: upgrade to latest release(0.9.3) | expand

Commit Message

Alper Ak Dec. 23, 2023, 7:35 a.m. UTC
* Dropped patch because fixed in the new version

Changelog:

* Fix XMP rotation bug
* add cmake as build system + add epeg_set/get_orientation + fix memleak in epeg_close
* minor fixes to build on windows + enable build of command line tool with cmake
* configure: Fix checks for libjpeg and libexif

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 ...e-Fix-checks-for-libjpeg-and-libexif.patch | 32 -------------------
 .../epeg/{epeg_git.bb => epeg_0.9.3.bb}       |  7 ++--
 2 files changed, 3 insertions(+), 36 deletions(-)
 delete mode 100644 meta-oe/recipes-support/epeg/epeg/0001-configure-Fix-checks-for-libjpeg-and-libexif.patch
 rename meta-oe/recipes-support/epeg/{epeg_git.bb => epeg_0.9.3.bb} (80%)
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/epeg/epeg/0001-configure-Fix-checks-for-libjpeg-and-libexif.patch b/meta-oe/recipes-support/epeg/epeg/0001-configure-Fix-checks-for-libjpeg-and-libexif.patch
deleted file mode 100644
index 1568fe96e..000000000
--- a/meta-oe/recipes-support/epeg/epeg/0001-configure-Fix-checks-for-libjpeg-and-libexif.patch
+++ /dev/null
@@ -1,32 +0,0 @@ 
-From 4e0c62634b0db6dbad0d41377bb71a8012abd75b Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 1 Sep 2022 12:56:54 -0700
-Subject: [PATCH] configure: Fix checks for libjpeg and libexif
-
-Use the functions from the respective library instead of using main
-function which is not part of library
-
-Upstream-Status: Submitted [https://github.com/mattes/epeg/pull/27]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- configure.ac | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index a4f6ebd..e474b1d 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -31,8 +31,8 @@ AC_SUBST(version_info)
- dnl AC_CHECK_FUNCS(fmemopen)
- dnl AC_CHECK_FUNCS(open_memstream)
- 
--AC_CHECK_LIB([jpeg], [main], [], [echo "libjpeg library not found. Please install it before proceeding"; exit -1])
--AC_CHECK_LIB([exif], [main], [], [echo "libexif library not found. Please install it before proceeding"; exit -1])
-+AC_CHECK_LIB([jpeg], [jpeg_simple_progression], [], [echo "libjpeg library not found. Please install it before proceeding"; exit -1])
-+AC_CHECK_LIB([exif], [exif_data_new_from_file], [], [echo "libexif library not found. Please install it before proceeding"; exit -1])
- 
- my_includes=""
- my_libs="-ljpeg -lexif"
--- 
-2.37.3
-
diff --git a/meta-oe/recipes-support/epeg/epeg_git.bb b/meta-oe/recipes-support/epeg/epeg_0.9.3.bb
similarity index 80%
rename from meta-oe/recipes-support/epeg/epeg_git.bb
rename to meta-oe/recipes-support/epeg/epeg_0.9.3.bb
index e5277b157..f70c3dd1e 100644
--- a/meta-oe/recipes-support/epeg/epeg_git.bb
+++ b/meta-oe/recipes-support/epeg/epeg_0.9.3.bb
@@ -3,12 +3,11 @@  DESCRIPTION = "Insanely fast JPEG/ JPG thumbnail scaling with the minimum fuss a
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYING;md5=e7732a9290ea1e4b034fdc15cf49968d \
                     file://COPYING-PLAIN;md5=f59cacc08235a546b0c34a5422133035"
+
 DEPENDS = "jpeg libexif"
 
-SRC_URI = "git://github.com/mattes/epeg.git;branch=master;protocol=https \
-           file://0001-configure-Fix-checks-for-libjpeg-and-libexif.patch \
-           "
-SRCREV = "9a175cd67eaa61fe45413d8da82da72936567047"
+SRC_URI = "git://github.com/mattes/epeg.git;branch=master;protocol=https"
+SRCREV = "17bbae0f0a0b777e5fb01e0d16891e07153a41eb"
 S = "${WORKDIR}/git"
 
 inherit autotools pkgconfig