diff mbox series

[meta-oe] wavpack: add PACKAGECONFIG for shared and enable it by default

Message ID 20231222134620.3710023-1-martin.jansa@gmail.com
State New
Headers show
Series [meta-oe] wavpack: add PACKAGECONFIG for shared and enable it by default | expand

Commit Message

Martin Jansa Dec. 22, 2023, 1:46 p.m. UTC
* fixes gstreamer1.0-plugins-good build with wavpack enabled:
  PACKAGECONFIG:append:pn-gstreamer1.0-plugins-good = " wavpack"

* 5.1.0 built shared libs by default, 5.6.0 build with CMake doesn't, causing:
  http://errors.yoctoproject.org/Errors/Details/748247/

TOPDIR/tmp-glibc/work/cortexa57-oe-linux/gstreamer1.0-plugins-good/1.22.7/recipe-sysroot-native/usr/bin/aarch64-oe-linux/../../libexec/aarch64-oe-linux/gcc/aarch64-oe-linux/13.2.0/ld: TOPDIR/tmp-glibc/work/cortexa57-oe-linux/gstreamer1.0-plugins-good/1.22.7/recipe-sysroot/usr/lib/libwavpack.a(read_words.c.o): relocation R_AARCH64_ADR_PREL_PG_HI21 against symbol `bitset' which may bind externally can not be used when making a shared object; recompile with -fPIC
/usr/src/debug/wavpack/5.6.0/src/read_words.c:592:(.text+0xb88): dangerous relocation: unsupported relocation
collect2: error: ld returned 1 exit status

Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
---
 meta-oe/recipes-multimedia/wavpack/wavpack_5.6.0.bb | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta-oe/recipes-multimedia/wavpack/wavpack_5.6.0.bb b/meta-oe/recipes-multimedia/wavpack/wavpack_5.6.0.bb
index ebbc59dde8..1011cd4c03 100644
--- a/meta-oe/recipes-multimedia/wavpack/wavpack_5.6.0.bb
+++ b/meta-oe/recipes-multimedia/wavpack/wavpack_5.6.0.bb
@@ -9,3 +9,6 @@  SRCREV = "e03e8e29dc618e08e7baba9636e57ba1254874ce"
 S = "${WORKDIR}/git"
 
 inherit cmake pkgconfig
+
+PACKAGECONFIG = "shared"
+PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF,,"