diff mbox series

[meta-python] python3-wpa-supplicant: fix upstream uri and version check

Message ID 20231221181726.3904826-1-derek@asterius.io
State Accepted
Headers show
Series [meta-python] python3-wpa-supplicant: fix upstream uri and version check | expand

Commit Message

Derek Straka Dec. 21, 2023, 6:17 p.m. UTC
Signed-off-by: Derek Straka <derek@asterius.io>
---
 .../recipes-devtools/python/python3-wpa-supplicant_0.2.bb       | 2 ++
 1 file changed, 2 insertions(+)

Comments

Khem Raj Dec. 27, 2023, 8:21 a.m. UTC | #1
On Thu, 21 Dec 2023 18:17:26 +0000, Derek Straka wrote:
> 


Applied, thanks!

[1/1] python3-wpa-supplicant: fix upstream uri and version check
      commit: a28ead8652868a978bfcd99c4a366739d7c8fd70

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-wpa-supplicant_0.2.bb b/meta-python/recipes-devtools/python/python3-wpa-supplicant_0.2.bb
index 5ac7786ad..b9c62ced7 100644
--- a/meta-python/recipes-devtools/python/python3-wpa-supplicant_0.2.bb
+++ b/meta-python/recipes-devtools/python/python3-wpa-supplicant_0.2.bb
@@ -10,6 +10,8 @@  SRC_URI[sha256sum] = "3ad0f40a696763bb0f4d4dec5b51f6b53ccfeb7c16ebb5897349303045
 SRC_URI += "file://0001-cli-drop-the-second-argument-from-click.argument-dec.patch"
 
 PYPI_PACKAGE = "wpa_supplicant"
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/wpa_supplicant"
+UPSTREAM_CHECK_REGEX = "/wpa_supplicant/(?P<pver>(\d+[\.\-_]*)+)"
 
 inherit pypi setuptools3