diff mbox series

[meta-networking,v2] networkmanager: fix some missing pkgconfig

Message ID 20231220141550.1777282-1-thomas.perrot@bootlin.com
State Accepted
Headers show
Series [meta-networking,v2] networkmanager: fix some missing pkgconfig | expand

Commit Message

Thomas Perrot Dec. 20, 2023, 2:15 p.m. UTC
From: Thomas Perrot <thomas.perrot@bootlin.com>

- to build and package nmtui
- to automatically append networkmanager-adsl and
  networkmanager-wwan in recommended packages.
- to fix an invalid-packageconfig QA issue that is raised when
  adsl and wwan are added in pkgconfig.

Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com>
---
 .../networkmanager/networkmanager_1.44.0.bb                  | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Ross Burton Dec. 20, 2023, 2:47 p.m. UTC | #1
On 20 Dec 2023, at 14:15, Thomas Perrot via lists.openembedded.org <thomas.perrot=bootlin.com@lists.openembedded.org> wrote:
> 
> +RDEPENDS:${PN}-nmtui += "${PN}-daemon ${@bb.utils.contains('PACKAGECONFIG','nmtui','libnewt','',d)}”

My point still remains: it looks like nmtui links to libnewt directly and doesn’t dlopen, so why is this needed?

https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/blob/main/src/libnmt-newt/meson.build?ref_type=heads#L29

Ross
Thomas Perrot Dec. 21, 2023, 6:59 a.m. UTC | #2
On Wed, 2023-12-20 at 14:47 +0000, Ross Burton wrote:
> On 20 Dec 2023, at 14:15, Thomas Perrot via lists.openembedded.org
> <thomas.perrot=bootlin.com@lists.openembedded.org> wrote:
> > 
> > +RDEPENDS:${PN}-nmtui += "${PN}-daemon
> > ${@bb.utils.contains('PACKAGECONFIG','nmtui','libnewt','',d)}”
> 
> My point still remains: it looks like nmtui links to libnewt directly
> and doesn’t dlopen, so why is this needed?

This is a mistake, this isn't necessary, thank you.

Kind regards,
Thomas Perrot

> 
> https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/blob/main/src/libnmt-newt/meson.build?ref_type=heads#L29
> 
> Ross
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#107661):
> https://lists.openembedded.org/g/openembedded-devel/message/107661
> Mute This Topic: https://lists.openembedded.org/mt/103281132/5443093
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe:
> https://lists.openembedded.org/g/openembedded-devel/unsub [
> thomas.perrot@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj Dec. 27, 2023, 8:21 a.m. UTC | #3
On Wed, 20 Dec 2023 15:15:50 +0100, thomas.perrot@bootlin.com wrote:
> - to build and package nmtui
> - to automatically append networkmanager-adsl and
>   networkmanager-wwan in recommended packages.
> - to fix an invalid-packageconfig QA issue that is raised when
>   adsl and wwan are added in pkgconfig.
> 
> 
> [...]

Applied, thanks!

[1/1] networkmanager: fix some missing pkgconfig
      commit: c331f59e42e9c0bda9d47d0365e6c276746fc81d

Best regards,
diff mbox series

Patch

diff --git a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.44.0.bb b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.44.0.bb
index 867d13327144..f50cb842dbb7 100644
--- a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.44.0.bb
+++ b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.44.0.bb
@@ -111,6 +111,7 @@  PACKAGECONFIG[iwd] = "-Diwd=true,-Diwd=false"
 PACKAGECONFIG[ifupdown] = "-Difupdown=true,-Difupdown=false"
 PACKAGECONFIG[cloud-setup] = "-Dnm_cloud_setup=true,-Dnm_cloud_setup=false"
 PACKAGECONFIG[nmcli] = "-Dnmcli=true,-Dnmcli=false"
+PACKAGECONFIG[nmtui] = "-Dnmtui=true,-Dnmtui=false,libnewt"
 PACKAGECONFIG[readline] = "-Dreadline=libreadline,,readline"
 PACKAGECONFIG[libedit] = "-Dreadline=libedit,,libedit"
 PACKAGECONFIG[ovs] = "-Dovs=true,-Dovs=false,jansson"
@@ -120,6 +121,8 @@  PACKAGECONFIG[vala] = "-Dvapi=true,-Dvapi=false"
 PACKAGECONFIG[dhcpcd] = "-Ddhcpcd=${base_sbindir}/dhcpcd,-Ddhcpcd=no,,dhcpcd"
 PACKAGECONFIG[dhclient] = "-Ddhclient=yes,-Ddhclient=no,,dhcp"
 PACKAGECONFIG[concheck] = "-Dconcheck=true,-Dconcheck=false"
+PACKAGECONFIG[adsl] = ",,"
+PACKAGECONFIG[wwan] = ",,"
 # The following PACKAGECONFIG is used to determine whether NM is managing /etc/resolv.conf itself or not
 PACKAGECONFIG[man-resolv-conf] = ",,"
 
@@ -189,7 +192,7 @@  FILES:${PN}-nmtui = " \
     ${bindir}/nmtui-connect \
     ${bindir}/nmtui-hostname \
 "
-RDEPENDS:${PN}-nmtui += "${PN}-daemon"
+RDEPENDS:${PN}-nmtui += "${PN}-daemon ${@bb.utils.contains('PACKAGECONFIG','nmtui','libnewt','',d)}"
 
 SUMMARY:${PN}-wifi = "Wifi plugin for NetworkManager"
 FILES:${PN}-wifi = "\