diff mbox series

[meta-networking] networkmanager: fix some missing pkgconfig

Message ID 20231220102355.1303991-1-thomas.perrot@bootlin.com
State Superseded
Headers show
Series [meta-networking] networkmanager: fix some missing pkgconfig | expand

Commit Message

Thomas Perrot Dec. 20, 2023, 10:23 a.m. UTC
From: Thomas Perrot <thomas.perrot@bootlin.com>

- to build and package nmtui
- to automatically append networkmanager-adsl and
  networkmanager-wwan in recommended packages.
- to fix an invalid-packageconfig QA issue that is raised when
  adsl and wwan are added in pkgconfig.

Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com>
---
 .../networkmanager/networkmanager_1.44.0.bb                    | 3 +++
 1 file changed, 3 insertions(+)

Comments

Ross Burton Dec. 20, 2023, 12:35 p.m. UTC | #1
Can you say “PACKAGECONFIG”, as pkgconfig is something else entirely.

> +PACKAGECONFIG[nmtui] = "-Dnmtui=true,-Dnmtui=false,libnewt,libnewt”

Doesn’t the shared library dependency happy automatically?  This puts the RDEPENDS on networkmanager, which isn’t the package containing nmtui.

Ross
Thomas Perrot Dec. 20, 2023, 1:30 p.m. UTC | #2
Hello,

On Wed, 2023-12-20 at 12:35 +0000, Ross Burton wrote:
> Can you say “PACKAGECONFIG”, as pkgconfig is something else entirely.
> 
> > +PACKAGECONFIG[nmtui] = "-Dnmtui=true,-
> > Dnmtui=false,libnewt,libnewt”
> 
> Doesn’t the shared library dependency happy automatically?  This puts
> the RDEPENDS on networkmanager, which isn’t the package containing
> nmtui.
> 

I agree, I'm submitting a v2 that adds the required dependency on
${PN}-nmtui instead.

Kind regards,
Thomas Perrot

> Ross
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#107655):
> https://lists.openembedded.org/g/openembedded-devel/message/107655
> Mute This Topic: https://lists.openembedded.org/mt/103278844/5443093
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe:
> https://lists.openembedded.org/g/openembedded-devel/unsub [
> thomas.perrot@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.44.0.bb b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.44.0.bb
index 867d13327144..7929ea02b3dc 100644
--- a/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.44.0.bb
+++ b/meta-networking/recipes-connectivity/networkmanager/networkmanager_1.44.0.bb
@@ -111,6 +111,7 @@  PACKAGECONFIG[iwd] = "-Diwd=true,-Diwd=false"
 PACKAGECONFIG[ifupdown] = "-Difupdown=true,-Difupdown=false"
 PACKAGECONFIG[cloud-setup] = "-Dnm_cloud_setup=true,-Dnm_cloud_setup=false"
 PACKAGECONFIG[nmcli] = "-Dnmcli=true,-Dnmcli=false"
+PACKAGECONFIG[nmtui] = "-Dnmtui=true,-Dnmtui=false,libnewt,libnewt"
 PACKAGECONFIG[readline] = "-Dreadline=libreadline,,readline"
 PACKAGECONFIG[libedit] = "-Dreadline=libedit,,libedit"
 PACKAGECONFIG[ovs] = "-Dovs=true,-Dovs=false,jansson"
@@ -120,6 +121,8 @@  PACKAGECONFIG[vala] = "-Dvapi=true,-Dvapi=false"
 PACKAGECONFIG[dhcpcd] = "-Ddhcpcd=${base_sbindir}/dhcpcd,-Ddhcpcd=no,,dhcpcd"
 PACKAGECONFIG[dhclient] = "-Ddhclient=yes,-Ddhclient=no,,dhcp"
 PACKAGECONFIG[concheck] = "-Dconcheck=true,-Dconcheck=false"
+PACKAGECONFIG[adsl] = ",,"
+PACKAGECONFIG[wwan] = ",,"
 # The following PACKAGECONFIG is used to determine whether NM is managing /etc/resolv.conf itself or not
 PACKAGECONFIG[man-resolv-conf] = ",,"