diff mbox series

[meta-python,3/4] python3-dominate: upgrade 2.8.0 -> 2.9.0

Message ID 20231218170901.1378254-3-leon.anavi@konsulko.com
State Accepted
Headers show
Series [meta-python,1/4] python3-sdbus: upgrade 0.11.0 -> 0.11.1 | expand

Commit Message

Leon Anavi Dec. 18, 2023, 5:09 p.m. UTC
Upgrade to version 2.9.0:

- Modernize setuptools support to use pyproject.toml
- Remove brittle test

Remove fix-ptests.patch as the issue has been solved upstream.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/python3-dominate/fix-ptests.patch  | 20 -------------------
 ...ate_2.8.0.bb => python3-dominate_2.9.0.bb} |  5 ++---
 2 files changed, 2 insertions(+), 23 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch
 rename meta-python/recipes-devtools/python/{python3-dominate_2.8.0.bb => python3-dominate_2.9.0.bb} (77%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch b/meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch
deleted file mode 100644
index 81211d449..000000000
--- a/meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch
+++ /dev/null
@@ -1,20 +0,0 @@ 
-Fixes test failures on musl
-
-Fixes errors
-ptestresult.python3-dominate.tests/test_dom_tag.py::test___get_thread_context
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-diff --git a/tests/test_dom_tag.py b/tests/test_dom_tag.py
-index 43ffecb..1126e54 100644
---- a/tests/test_dom_tag.py
-+++ b/tests/test_dom_tag.py
-@@ -18,6 +18,7 @@ def test___get_thread_context(monkeypatch):
-     monkeypatch.setattr(sut, 'threading', threading)
- 
-     assert sut._get_thread_context() in [
-+        1692341442, # Python >= 3.9, 32-bit
-         -6805948436281256182, # Python >= 3.9
-         3713141171098444831, # Python < 3.9
-     ]
diff --git a/meta-python/recipes-devtools/python/python3-dominate_2.8.0.bb b/meta-python/recipes-devtools/python/python3-dominate_2.9.0.bb
similarity index 77%
rename from meta-python/recipes-devtools/python/python3-dominate_2.8.0.bb
rename to meta-python/recipes-devtools/python/python3-dominate_2.9.0.bb
index 6b0489e4f..2234e541b 100644
--- a/meta-python/recipes-devtools/python/python3-dominate_2.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-dominate_2.9.0.bb
@@ -2,13 +2,12 @@  SUMMARY = "Dominate is a Python library for creating and manipulating HTML docum
 LICENSE = "LGPL-3.0-only"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
 
-SRC_URI[sha256sum] = "4c90c3befaf88e612b71f4b39af7bcbef8977acfa855cec957225a8fbf504007"
+SRC_URI[sha256sum] = "b15791ebea432218543a1702d76ae45d2ff95ff994e52014b8686a69dad772fd"
 
-inherit pypi setuptools3 ptest
+inherit pypi ptest python_setuptools_build_meta
 
 SRC_URI += " \
 	file://run-ptest \
-	file://fix-ptests.patch \
 "
 
 RDEPENDS:${PN}-ptest += " \