diff mbox series

[meta-python,3/6] python3-yarl: upgrade 1.9.2 -> 1.9.4

Message ID 20231215160103.2164505-3-leon.anavi@konsulko.com
State Accepted
Headers show
Series [meta-python,1/6] python3-expandvars: add recipe | expand

Commit Message

Leon Anavi Dec. 15, 2023, 4:01 p.m. UTC
Upgrade to version 1.9.4:

- Started raising :py:exc:TypeError when a string value is passed
  into :py:meth:~yarl.URL.build as the port argument -- by
  :user:commonism
- The leading -- has been dropped from the :pep:517 in-tree build
backend config setting names. --pure-python is now just pure-python
- A step-by-step :doc:Release Guide <contributing/release_guide>
  guide has been added, describing how to release yarl

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../{python3-yarl_1.9.2.bb => python3-yarl_1.9.4.bb}     | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-yarl_1.9.2.bb => python3-yarl_1.9.4.bb} (70%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-yarl_1.9.2.bb b/meta-python/recipes-devtools/python/python3-yarl_1.9.4.bb
similarity index 70%
rename from meta-python/recipes-devtools/python/python3-yarl_1.9.2.bb
rename to meta-python/recipes-devtools/python/python3-yarl_1.9.4.bb
index 63700024c..d9fe4c0c4 100644
--- a/meta-python/recipes-devtools/python/python3-yarl_1.9.2.bb
+++ b/meta-python/recipes-devtools/python/python3-yarl_1.9.4.bb
@@ -3,13 +3,18 @@  HOMEPAGE = "https://github.com/aio-libs/yarl/"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
-SRC_URI[sha256sum] = "04ab9d4b9f587c06d801c2abfe9317b77cdf996c65a90d5e84ecc45010823571"
+SRC_URI[sha256sum] = "566db86717cf8080b99b58b083b773a908ae40f06681e87e589a976faf8246bf"
 
 SRC_URI += "file://run-ptest"
 
 PYPI_PACKAGE = "yarl"
 
-inherit pypi ptest setuptools3
+inherit pypi ptest python_setuptools_build_meta
+
+DEPENDS += " \
+    ${PYTHON_PN}-expandvars-native \
+    ${PYTHON_PN}-cython-native \
+"
 
 RDEPENDS:${PN} = "\
     ${PYTHON_PN}-multidict \