diff mbox series

[meta-multimedia,1/2] rygel: fix build with gtk+3 PACKAGECONFIG disabled

Message ID 20231212125742.2494501-1-martin.jansa@gmail.com
State Accepted
Headers show
Series [meta-multimedia,1/2] rygel: fix build with gtk+3 PACKAGECONFIG disabled | expand

Commit Message

Martin Jansa Dec. 12, 2023, 12:57 p.m. UTC
* fixes:
  rygel-0.42.4/meson.build:1:0: ERROR: Value "false" (of type "string") for combo option "gtk" is not one of the choices. Possible choices are (as string): "enabled", "disabled", "auto".

* possibly changed since:
  https://github.com/GNOME/rygel/commit/7e1819d9e49084c9dc55064a6f21d0f7caa90da6

Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
---
 meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Khem Raj Dec. 13, 2023, 7:07 a.m. UTC | #1
On Tue, 12 Dec 2023 13:57:41 +0100, Martin Jansa wrote:
> * fixes:
>   rygel-0.42.4/meson.build:1:0: ERROR: Value "false" (of type "string") for combo option "gtk" is not one of the choices. Possible choices are (as string): "enabled", "disabled", "auto".
> 
> * possibly changed since:
>   https://github.com/GNOME/rygel/commit/7e1819d9e49084c9dc55064a6f21d0f7caa90da6
> 
> 
> [...]

Applied, thanks!

[1/2] rygel: fix build with gtk+3 PACKAGECONFIG disabled
      commit: cdaafdea99c6b49cc56216c6082722e01512a0cd
[2/2] rygel: add x11 to DISTRO_FEATURES
      commit: 23b62b3391f2e605f59e02abb3c99db2a7b82eb5

Best regards,
diff mbox series

Patch

diff --git a/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb b/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb
index 9662296399..5212e78333 100644
--- a/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb
+++ b/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb
@@ -37,7 +37,7 @@  PACKAGECONFIG[media-export] = ""
 PACKAGECONFIG[gst-launch] = ""
 PACKAGECONFIG[lms] = ""
 PACKAGECONFIG[tracker3] = ""
-PACKAGECONFIG[gtk+3] = ",-Dgtk=false,gtk+3"
+PACKAGECONFIG[gtk+3] = ",-Dgtk=disabled,gtk+3"
 
 RYGEL_PLUGINS = ""
 RYGEL_PLUGINS:append ="${@bb.utils.contains('PACKAGECONFIG', 'external', ',external', '', d)}"