diff mbox series

[meta-gnome,v2] mutter: Make gnome-desktop and libcanberra dependencies optional

Message ID 20231207153354.273551-1-zboszor@gmail.com
State Accepted
Headers show
Series [meta-gnome,v2] mutter: Make gnome-desktop and libcanberra dependencies optional | expand

Commit Message

Böszörményi Zoltán Dec. 7, 2023, 3:33 p.m. UTC
mutter may be used as a standalone compositor and even an X11 WM
without the complete GNOME desktop environment. Make this optional
and add the new control knob to PACKAGECONFIG by default.

The built-in sound player functionality depends on libcanberra
which is considered outdated. Make this optional.

Add the colord build dependency explicitly because mutter does
not build when PACKAGECONFIG = "gnome-desktop" is not used.

Add the gsettings-desktop-schemas runtime dependency explicitly,
so mutter may work without PACKAGECONFIG = "gnome-desktop".

This change allows mutter in kiosk-like scenarios.

Signed-off-by: Zoltán Böszörményi <zboszor@gmail.com>
---
 meta-gnome/recipes-gnome/mutter/mutter_45.1.bb | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

Comments

Khem Raj Dec. 13, 2023, 7:07 a.m. UTC | #1
On Thu, 07 Dec 2023 16:33:54 +0100, Zoltán Böszörményi wrote:
> mutter may be used as a standalone compositor and even an X11 WM
> without the complete GNOME desktop environment. Make this optional
> and add the new control knob to PACKAGECONFIG by default.
> 
> The built-in sound player functionality depends on libcanberra
> which is considered outdated. Make this optional.
> 
> [...]

Applied, thanks!

[1/1] mutter: Make gnome-desktop and libcanberra dependencies optional
      commit: d6f689da36fe88110d0fb7cad9a1bd84524d9e8c

Best regards,
diff mbox series

Patch

diff --git a/meta-gnome/recipes-gnome/mutter/mutter_45.1.bb b/meta-gnome/recipes-gnome/mutter/mutter_45.1.bb
index 60347aa49..6093a0fe9 100644
--- a/meta-gnome/recipes-gnome/mutter/mutter_45.1.bb
+++ b/meta-gnome/recipes-gnome/mutter/mutter_45.1.bb
@@ -6,6 +6,7 @@  DEPENDS = " \
     xserver-xorg-cvt-native \
     wayland-native \
     virtual/libx11 \
+    colord \
     graphene \
     gtk4 \
     gdk-pixbuf \
@@ -13,8 +14,6 @@  DEPENDS = " \
     pango \
     gsettings-desktop-schemas \
     json-glib \
-    gnome-desktop \
-    gnome-settings-daemon \
     libei \
     libxtst \
     libxkbfile \
@@ -41,6 +40,7 @@  PACKAGECONFIG ??= " \
     ${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'opengl glx', '', d)} \
     sm \
     startup-notification \
+    gnome-desktop \
 "
 
 EXTRA_OEMESON += " \
@@ -57,7 +57,9 @@  PACKAGECONFIG[libdisplay-info] = "-Dlibdisplay_info=true, -Dlibdisplay_info=fals
 PACKAGECONFIG[libwacom] = "-Dlibwacom=true, -Dlibwacom=false, libwacom"
 # Remove depending on pipewire-0.2 when mutter is upgraded to 3.36+
 PACKAGECONFIG[remote-desktop] = "-Dremote_desktop=true, -Dremote_desktop=false, pipewire"
+PACKAGECONFIG[gnome-desktop] = "-Dlibgnome_desktop=true, -Dlibgnome_desktop=false, gnome-desktop gnome-settings-daemon"
 PACKAGECONFIG[sm] = "-Dsm=true, -Dsm=false, libsm"
+PACKAGECONFIG[sound-player] = "-Dsound_player=true, -Dsound_player=false, libcanberra"
 PACKAGECONFIG[profiler] = "-Dprofiler=true,-Dprofiler=false,sysprof"
 PACKAGECONFIG[startup-notification] = "-Dstartup_notification=true, -Dstartup_notification=false, startup-notification, startup-notification"
 
@@ -102,5 +104,5 @@  FILES:${PN}-dev += " \
     ${libdir}/${MUTTER_API_NAME}/lib*.so \
 "
 
-RDEPENDS:${PN} += "zenity ${PN}-gsettings"
+RDEPENDS:${PN} += "zenity ${PN}-gsettings gsettings-desktop-schemas"