diff mbox series

[meta-oe] monocypher: pass LIBDIR to fix installed-vs-shipped QA issue with multilib

Message ID 20231206175453.2967092-1-martin.jansa@gmail.com
State Accepted
Headers show
Series [meta-oe] monocypher: pass LIBDIR to fix installed-vs-shipped QA issue with multilib | expand

Commit Message

Martin Jansa Dec. 6, 2023, 5:54 p.m. UTC
* fixes:
ERROR: monocypher-4.0.2-r0 do_package: QA Issue: monocypher: Files/directories were installed but not shipped in any package:
  /usr/lib/libmonocypher.so
  /usr/lib/libmonocypher.so.4
  /usr/lib/libmonocypher.a
  /usr/lib/pkgconfig
  /usr/lib/pkgconfig/monocypher.pc
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
monocypher: 5 installed and not shipped files. [installed-vs-shipped]

this only fixes the above issues, to make it usable with other
libdir values the .pc files would need to be fixed to respect passed
LIBDIR value as well as now they expect just lib:
monocypher.pc:libdir=${exec_prefix}/lib
tests/speed/libhydrogen.pc:libdir=${exec_prefix}/lib

Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
---
 meta-oe/recipes-crypto/monocypher/monocypher_4.0.2.bb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Khem Raj Dec. 13, 2023, 7:07 a.m. UTC | #1
On Wed, 06 Dec 2023 18:54:53 +0100, Martin Jansa wrote:
> * fixes:
> ERROR: monocypher-4.0.2-r0 do_package: QA Issue: monocypher: Files/directories were installed but not shipped in any package:
>   /usr/lib/libmonocypher.so
>   /usr/lib/libmonocypher.so.4
>   /usr/lib/libmonocypher.a
>   /usr/lib/pkgconfig
>   /usr/lib/pkgconfig/monocypher.pc
> Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
> monocypher: 5 installed and not shipped files. [installed-vs-shipped]
> 
> [...]

Applied, thanks!

[1/1] monocypher: pass LIBDIR to fix installed-vs-shipped QA issue with multilib
      commit: 0cda5a8fb9fb5bc309ba470fceccf65e8bd121d2

Best regards,
diff mbox series

Patch

diff --git a/meta-oe/recipes-crypto/monocypher/monocypher_4.0.2.bb b/meta-oe/recipes-crypto/monocypher/monocypher_4.0.2.bb
index 899638161a..e6380d9a20 100644
--- a/meta-oe/recipes-crypto/monocypher/monocypher_4.0.2.bb
+++ b/meta-oe/recipes-crypto/monocypher/monocypher_4.0.2.bb
@@ -11,8 +11,8 @@  SRCREV = "0d85f98c9d9b0227e42cf795cb527dff372b40a4"
 
 S = "${WORKDIR}/git"
 
-CFLAGS+="-pedantic -Wall -Wextra -O3"
-EXTRA_OEMAKE = "'PREFIX=${prefix}' 'DESTDIR=${D}' 'CFLAGS=${CFLAGS}'"
+CFLAGS += "-pedantic -Wall -Wextra -O3"
+EXTRA_OEMAKE = "'PREFIX=${prefix}' 'DESTDIR=${D}' 'CFLAGS=${CFLAGS}' 'LIBDIR=${libdir}'"
 
 do_compile() {
     oe_runmake library